WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Social Connect] Twitter Login don't work

[Resolved] [Plugin: Social Connect] Twitter Login don't work

Viewing 13 replies - 1 through 13 (of 13 total)
  • I’ve the same issue, I think is because twitter changed its api, anyone knows a fix?

    I was having a similar issue yesterday – even this morning. And NOW – it magically works. Have you tried your Twitter login again recently? I’m curious if they simply fixed something that would fix it for all of us.

    Wups. I spoke too soon. NOW I can actually see the twitter app login page, but when I go to login, instead of being redirected, I get that exact same message you got:
    Fatal error: Uncaught exception 'EpiOAuthException' with message '{"errors":[{"message":"Sorry, that page does not exist","code":34}]}' in /home/www/simplythreetrio.com/wp-content/plugins/thenbrent-social-connect-9f825ec/twitter/EpiOAuth.php:251 Stack trace: #0 /home/www/simplythreetrio.com/wp-content/plugins/thenbrent-social-connect-9f825ec/twitter/EpiTwitter.php(100): EpiOAuthException::raise('{"errors":[{"me...', 404) #1 /home/www/simplythreetrio.com/wp-content/plugins/thenbrent-social-connect-9f825ec/twitter/callback.php(17): EpiTwitterJson->__get('name') #2 {main} thrown in /home/www/simplythreetrio.com/wp-content/plugins/thenbrent-social-connect-9f825ec/twitter/EpiOAuth.php on line 251

    Maybe they are working on it as we speak? Cuz I don’t think I ever actually got the initial Twitter login page…Progress?… Fingers crossed…

    Hey switch to WordPress Social Login. It works, even Twitter, if you follow the directions to update the Twitter app settings. And it works perfectly with Theme My Login.

    @zackcello thank you for the tip. WordPress Social Login works perfectly!

    My pleasure! Actually, problems developed for me with Social Login, too. And I now use Janrain , free version. http://wordpress.org/extend/plugins/rpx/

    Maybe your Social Login will be flawless, but in case you see problems later, you know what to do! 🙂

    Hi there!

    I’ve had the same problems as mentioned above: facebook works, twitter doesn’t. Here are the steps I did to fix the issue. Note that this is not a perfect solution, however I wanted to keep the social-connect plugin.

    First, note that the URLs in the social-connect (SC) are a bit old. Once you register an app, the dev.twitter.com will list the https://api.twitter.com/oauth/, where the SC has http://twitter.com/oauth/ in its EpiTwitter.php, so this will most probably change. For now however, it will work.

    Second, we can do a bit of tracing in the SC callback.php (plugins/social-connect/twitter/callback.php). In my case, I’ve narrowed the problem between the

    $user=$twitter_api->get_accountVerify_credentials()

    and the

    $signature = social_connect_generate_signature($twitter_id)

    If we put a

    print_r($user); die();

    we will see that Twitter does its job. The problem most probably is in the function call of $user->name and $user->screen_name, since they produce the errors. However, the $user object already holds everything we need, if we do a

    $user_str = serialize($user);

    and then

    preg_match("/user_id=([0-9]*)/", $user_str, $match_id);
    $twitter_id=$match_id[1];
    preg_match("/screen_name=([a-zA-Z0-9_]{1,15}&?)/", $user_str, $match_user);
    $screen_name=$match_user[1];

    and leave everything else as is, it should work.

    THANKS TO raptusyu I APPLY YOUR SOLUTION IT WORKS LIKE CHARM.
    I REMOVE THE LINES

    $name = $user->name;
    $screen_name = $user->screen_name;
    $twitter_id = $user->id;

    AND INSERT

    $user_str = serialize($user);
    preg_match(“/user_id=([0-9]*)/”, $user_str, $match_id);
    $twitter_id=$match_id[1];
    preg_match(“/screen_name=([a-zA-Z0-9_]{1,15}&?)/”, $user_str, $match_user);
    $screen_name=$match_user[1];

    ON ITS PLACE THEN TRY IT WOW IT’S WORKING

    Hey guys I tried raptusyu’s solution since they seem to work for FATIMA124 but it didn’t work for me. I get the followgin error after editing the callback.php fiel:

    Fatal error: Call to undefined function phprequire_once() in /home/mydomain/public_html/wp-content/plugins/social-connect/twitter/callback.php on line 1

    any suggestions? thanks

    phprequire_once()

    @fatima124 Glad it worked 🙂

    @ebarcena You need a space between <?php and require_once()

    Thanks a lot raptusyu! That did the trick 😉

    this github pull fixes it

    https://github.com/lesfar/social-connect/commit/95b545c6f0fbe6f335da1b00b2e1b4e336be8ce9

    however the plugin author does not seem very active…

    justbishop

    @justbishop

    None of these fixes are working for me. I’m not very familiar with github. I c/p’d the code in each of the files into the SC existing files, replacing the original code in each. There wasn’t a pre-existing folder/file for the last one, so I created all of that from scratch and uploaded via FTP. Was I supposed to do something else?

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] [Plugin: Social Connect] Twitter Login don't work’ is closed to new replies.