Support » Plugin: Social Connect » [Plugin: Social Connect] Curl not properly configured

Viewing 5 replies - 1 through 5 (of 5 total)
  • I’d love to hear those fixes, as I just ran into issues related to
    CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set

    Plugin Author thenbrent

    (@thenbrent)

    Fixes gladly accepted via Github: https://github.com/thenbrent/social-connect

    Or i have downloaded a wrong solution, or something is wrong.
    If possible can you point me to a zip file with correction?

    When i activate: Google, Yahoo or WordPress i get next error:

    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /home/xxxxx/public_html/wp-content/plugins/social-connect/openid/openid.php on line 138

    Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set in /home/xxxxx/public_html/wp-content/plugins/social-connect/openid/openid.php on line 138

    Warning: Cannot modify header information – headers already sent by (output started at /home/xxxxx/public_html/wp-content/plugins/social-connect/openid/openid.php:138) in /home/xxxxx/public_html/wp-content/plugins/social-connect/google/connect.php on line 10

    Regards Danny

    I have changed: line 138 into:
    curl_setopt($curl, CURLOPT_FOLLOWLOCATION, false);
    instead
    curl_setopt($curl, CURLOPT_FOLLOWLOCATION, true);
    And now Google login works.
    Yahoo login gives: server not found.

    Regards, Danny

    Yahoo servers seems to have a different than this one in the source.
    Does anybody know the new server name?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Social Connect] Curl not properly configured’ is closed to new replies.