WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Sociable] Will Not Display the Pics

[Plugin: Sociable] Will Not Display the Pics

  • I’ve uploaded the whole folder but firefox will not load the pictures, it just loads the text. When I open it in another web browser (like IE or safari) it shows its trying to load the pictures but they are empty

    the site is http://www.resumeplay.net

    thanks for the help 😀

Viewing 15 replies - 1 through 15 (of 33 total)
  • Quick-and-dirty howto:
    1. Update plugin
    2. Comment this
    //$sociablepluginpath = plugins_url('', __FILE__).'/';
    3. Insert this (function Edit in Admin interface) from the old plugin
    $sociablepluginpath = WP_CONTENT_URL.'/plugins/'.plugin_basename(dirname(__FILE__)).'/';
    4. Ready.

    That can be an compatibility issue.

    the plug-in is trying to use:
    /wp-content/plugins/images/email_link.png

    instead of the correct url:
    /wp-content/plugins/sociable/images/email_link.png

    The fix from aka-es will not work unfortunately.

    It’s not just pics. WP also fails to load sociable.css.

    This latest version (today) isn’t fixable (for me) – going back to past version with icons showing.
    🙂
    It’s a great plugin, thank you.

    does anyone know where the previous version is available from? It appears that 2 versions were quickly put out one after the other.

    I had to replace the line of code in the plugin where it determines the path, back to the way it used to do it before the current update.

    Specifically, in sociable.php, near the beginning, I changed the line of code back to this:

    // Guess the location
    $sociablepluginpath = WP_CONTENT_URL.'/plugins/'.plugin_basename(dirname(__FILE__)).'/';

    from this:

    // Determine the location
    $sociablepluginpath = plugins_url('', __FILE__).'/';

    That seems to have made the icons appear again.

    worked a treat, thank you ardee00

    ardee00

    Thanks for your tip, my problem with images was solved 🙂

    Regards

    ardee00 – Made the difference for me too! Thanks for the fix.

    Thanks ardee00 – your tip was sound as a pound. Rock on!

    Thanks for the fix, this works great!

    Thanks for all the comments everybody, but sadly none of this worked out for me. I use the atahualpa theme but shouldn’t be a problem.

    I changed the code… nothing… I even went back to an older version (3.3.1) and changed the code around… nothing.

    This is such an awesome plugin that i really want to work with but its being stubborn for me. let me know if there are any other fixes you can think of

    Can I ask all of you which WordPress version you’re on?

    Thanks ardee00! Your fix solved my problem.

    @joostdevalk: I’m working with the german 2.7.1.

    Best regards from Cologne

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘[Plugin: Sociable] Will Not Display the Pics’ is closed to new replies.
Skip to toolbar