Support » Plugins and Hacks » [Plugin: Sociable] Icons Don’t Show in Settings Post

[Plugin: Sociable] Icons Don’t Show in Settings Post

  • Hi – (1) no icons show in my Sociable Settings page or in my post. When I first activated Sociable they were there, then they disappeared + I get text-only links in settings page + post.

    They disappeared after I clicked on multiple icons (about 8) to test them in browser. Then when I went back into sociable settings, the icons had gone. And when I refreshed post in browser, they switched to text links.

    “Disable sprite usage for images?” and “Use text links without images?” are both unchecked.

    I tried deleting Sociable, redownloading + re-installing it, but this does not help. I still get text only, no icons. I see in the \images folder, all the icons are there.

    I tried deleting sociable, exiting out of wordpress as admin, deleting all cookies, warm-booting computer, logging back into wp admin + reinstalling sociable, but it still doesn’t show icons.

    Also the text that was in the tagline: Share + Enjoy: which I deleted originally, does not appear either, even though it’s a brand new installation (with no cookies).

    I also tried logging in with different browser, but still no icons or text in tagline.

    Any idea how I can get the icons back into sociable settings page + my post?

    (2) Also the links display vertically instead of horizontally. I searched + saw someone else asked this question but no one replied. Any idea how to get the links to display horizontally? I see the css looks correct:

    .sociable ul {
    display: inline; etc;
    .sociable ul li {
    background: none;
    display: inline !important;

    I can get it to display horizontally if I disable the sociable.css in settings and instead use this in template:

    <?php if (function_exists(‘sociable_html’)) {echo sociable_html(); } ?>

    be grateful for help – thanks! – Val

Viewing 7 replies - 1 through 7 (of 7 total)
  • It seems wordpress somehow stores settings even after a plugin has been deleted and cookies/cache both cleared. This is because it doesn’t show the “share + enjoy” line in the settings in a new installation, as it did in the original installation.

    At one point after I saw the icons turn into text links, I saw the “Disable sprite usage for images?” was checked. I unchecked it (I can’t imagine I would ever have checked it in the first place!) but it’s obviously that which wordpress has stored in its memory and I can’t delete, even when the plugin is deleted.

    Is the only way to re-install wordpress?

    thanks, Val

    Eric Amundson


    Volunteer Moderator

    Hi Val,

    Some plugins do ‘store settings’ by creating, or adding to, database tables in WordPress. As far as I know, Sociable isn’t one of them.

    I’d look at your permissions for the plugin and also make sure your theme contains the necessary hooks to display the social networking links.


    I have the same problem: no icons, vertical display on one blog.

    I deleted the plugin, and used phpMyAdmin to delete the sociable db tables, then reinstalled with no apparent difference.

    Wp 2.9.2
    Sociable 3.5.2
    Theme: Eximius 1.04 also tried WordPress Classic 1.5 by Dave Shea

    Hi Robin – how do I delete the sociable db tables in phpMyAdmin? I’m new to this and haven’t used phpMyAdmin except for query strings when someone gives me the string.

    thanks, Val

    Just go to your PHP admin -> Select the database of your blog.
    Then on your left you have all the tables.
    Select the wp_options table. You will find a lot of lines there refering to Sociable. Delete all those lines and then re-install the plugin.
    If you change the Sociable.css file, don’t forget to back it up so you don’t have to re-style everything all over again.
    Hope this helps you

    Hi – oh dear, I went to wp_options but nothing there re sociable. I see the plugin’s only compatible to wordpress 2.8 + Joost in Holland (who took it over from its original creator) hasn’t replied in these forums for months so perhaps he doesn’t have time to upgrade it to be compatible with 2.9.

    Is there anywhere else besides wp_options where it could be storing settings? The fact that the text that was in the tagline: <b>Share + Enjoy:</b> which I deleted in the first installation, does not appear in every new install – even though it’s a brand new installation (with no cookies or cache) – means that sociable is storing something somewhere! Which it’s not deleting when it’s deleted from plugins.

    thanks, Val

    Sociable is compatible with wordpress 2.9.2.. I am using it.

    In my options table I find a lot of lines from Sociable:

    sociable_usecss yes
    sociable_iframewidth 800 yes
    sociable_iframeheight 500 yes
    sociable_conditionals a:9:{s:7:”is_home”;b:0;s:9:”is_single”;b:1;s:7:”is… yes
    sociable_tagline Share: yes
    yoastdbwidget a:1:{s:14:”removedbwidget”;b:1;} yes
    sociable_useiframe 1

    They start in line 3261. Your are probably in another lines. But make sure you are seeing all the lines in your table. My page only display 30 lines per page. Make sure to navigate trough all the lines in your options table.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Sociable] Icons Don’t Show in Settings Post’ is closed to new replies.