WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Sociable] Using deprecated user capability functions

[Plugin: Sociable] Using deprecated user capability functions

  • When testing themes with WP_DEBUG on this plugin is giving a deprecation notice regarding user capabilities.

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead.

    I am starting to use Sociable a lot and it would be great if this minor issue were resolved. Thank you BlogPlay for maintaining such a useful plugin/feature.

    http://wordpress.org/extend/plugins/sociable/

Viewing 2 replies - 1 through 2 (of 2 total)
  • I’m not sure how to contact BlogPlay but if anyone involved with Sociable could replace line 1013:

    add_options_page('Sociable', 'Sociable', 8, 'Sociable', 'sociable_submenu');

    with

    add_options_page('Sociable', 'Sociable', 'manage_options', 'Sociable', 'sociable_submenu');

    I would really appreciate it. I love Sociable, and I love the WordPress plugin but the deprecated numeric ‘has_cap’ E_NOTICE is driving me crazy while I’m developing 😉

    Thanks.

    Also could you search and replace:

    attribute_escape

    with:

    esc_attr

    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Sociable] Using deprecated user capability functions’ is closed to new replies.