Support » Plugins and Hacks » [Resolved] [Plugin: Sociable] Target=_blank not working in all sites not showing in RSS

[Resolved] [Plugin: Sociable] Target=_blank not working in all sites not showing in RSS

  • Hi, well I downloaded Sociable because I liked how it works but upon installation I ran into this errors:

    First the Target=_blank option is not working in all of the buttons (facebook, twitter, myspace, are the ones that don’t work so far), no matter what I do they just won’t open in a new tab or window.

    Second, it’s not showing sociable in my RSS feed (I’m using regular RSS not Feedburner), also tried everything I coud to make it work.

    Any kind of feed back or help would be awesome, thanks in advance.

    P.S.: I’m using WP 2.8 and Sociable 3.3

Viewing 9 replies - 1 through 9 (of 9 total)
  • I had the same problem and I solved it writing the “_blank” string directly into the code of sociable.php file.
    I know that is not the cleaner solution but it goes! So if you want to do the same thing open the sociable.php file. Search lines 52 and insert the bold code.

    $link .= "<a <strong>target=\"_blank\"</strong> rel=\"nofollow\"";
    		if (get_option('sociable_usetargetblank') && empty($site['awesm_channel'])) {
    			$link .= " target=\"_blank\"";

    After that Save file modification + Deactive plugin + Active plugin + Try and let me know 🙂

    Drizzi thank you very much!!, it worked like a charm all of them now target
    _blank, so I am a happy man.

    There is however a little error in the code, you added “strong” tags to it and when I pasted to my sociables.php got my page all scrambled up, it’s just a little error but you should modify it for other users sake.

    Still my feed remain without the sociables option, I gues I’ll have to live with this little problem, thanks again for the great help.

    I’ve made the change to feedburner so I really don’t need the fix for the rss, so I will concider this resolved, thanks again to drizzi for the help.

    It’s a very simple bug on the “_blank” problem. Sociable will be fully functional if you just replace drizzy’s bit of code with this. The bug is that the boolean operator “||” should have been used instead of “&&”.

    $link .= "<a rel=\"nofollow\"";
    		if (get_option('sociable_usetargetblank') || empty($site['awesm_channel'])) {
    			$link .= " target=\"_blank\"";

    Will be fixed in 3.3.1, thanks for noticing!

    Help the sociable Target=_blank not working in version 3.5.1. Any chance for a fix?



    Are you sure you have upgraded to 3.5.1? We fixed those two issues. Send us a screenshot at info@blogplay.com if it still doesn’t work

    I have 3.5.1 and not all of the links open a new window. Until I saw this thread I figured it was that those sites were using a no-frames script.

    If my assumption is incorrect, what would you need a screenshot of?

    Also, in IE8 the iframes open halfway down in my browser window, with no way to view the bottom of the frame. Works fine in FF. Drat IE, but can this be fixed?


Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] [Plugin: Sociable] Target=_blank not working in all sites not showing in RSS’ is closed to new replies.