Support » Plugins » [Plugin: Sociable] “save changes” will not save.

  • Hi,

    I’m having a problem with saving the settings in Sociable plugin. After many attempts to change the settings, it always reverts to the default settings.

    I want to be able to open link in a new window and add more sites.

    Anyone know how this can be fixed?


Viewing 13 replies - 1 through 13 (of 13 total)
  • I am having a VERY similar problem (on WP 2.6, but I did have the issue with 2.7). I am using IIS7 (because I want both PHP and ASP.NET) with Godaddy. The changes are not save, but this only happens with certain plugins.. and then some plugins save the changes fine… additionally, I cannot change the header theme image. I don;t mind cause I worked my way around it, but when I try to upload an image, and when I click the button to save it, it brings me back to the “General Settings”… anytime I am at Gerenal Settings after attempting to save changes from a lugin or something, I know it didn’t work 🙁
    Anyone have any ideas???

    Same issue… but this is the only plugin I’m currently seeing the problem with.

    I am having the same problem on WP 2.7 I can’t change the settings and save them

    I’m having this problem as well and am also using WordPress 2.7 with IIS 7 on go-daddy hosting.

    Same problem here too. I also have WordPress 2.7 and IIS 7.

    For various reasons, this one included, I switched to linux hosting via GoDaddy. For those using GoDaddyI was able to switch over without any data loss or problems with my wordpress installation. GoDaddy provides instructions here:

    I hope this helps.

    Thanks friarzero, for the tip about switching to Linux on GoDaddy, I’ve been told it’s a better operating system. I’ve just implemented the change so I’m hoping all goes well.

    Anybody know how to correct this? It’s highly irritating. I really want to use this, but the changes will not save. Looking at the code, I don’t believe there’s a way to do this manually either.

    Same problem here! Pressing “Save Changes” just takes me back to the main Settings page. I have the problem with WordPress 2.6 and 2.7. And, same thing happens with version 2.9.15 and 3.0.6 of Sociable. Happens using IE7 or Firefox 3.

    Can someone PLEASE address this?

    After hours of looking through the code, I’ve resolved this problem.

    STEP 1: Open sociable.php

    STEP 2: Find <form action=”<?php echo attribute_escape( $_SERVER[‘REQUEST_URI’] ); ?> method=”post”> and delete it

    STEP 3: In its place, paste this code: <form action=”” method=”post”>

    When you click “save changes,” everything will now save.

    @ gsipruitt:

    Thanks, that worked for me!

    On my computer, I just opened the file using Notepad, found the section of code using “Edit”->”Find” and then carefully replaced it as you said. Then I used my ftp client to upload the new sociable.php file.

    it didnt work for me, any other suggestions?

    same problem with eg-series plug-in. it’s not saving changes and after i click sace changes at new pages all boxes are appearing empty. any suggestions?

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Sociable] “save changes” will not save.’ is closed to new replies.