WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Sociable] Problem posting to digg

[Plugin: Sociable] Problem posting to digg

  • When clicking the icon to submit a story to Digg the article is not correctly picked up because the URL is garbled. It appears that an ampersand is not correctly escaped. For instance go to my site, anotherearlymorning.com, click on a post, then try to submit it to digg.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I’m noticing the same issue on my site with links to Digg, Google, and Tumblr. I’m using Sociable 3.4.4, WordPress 2.8.3.

    Fixed, I think. In sociable.php, I changed the URLs to the following which appear to be working just fine:

    'Digg' => Array(
    		'favicon' => 'digg.png',
    		'url' => 'http://digg.com/submit?url=PERMALINK&title=TITLE',
    	),
    
    'Google' => Array (
    		'favicon' => 'googlebookmark.png',
    		'url' => 'http://www.google.com/bookmarks/mark?op=edit&bkmk=PERMALINK&title=TITLE&annotation=EXCERPT',
    		'description' => 'Google Bookmarks'
    	),
    
    'Tumblr' => Array(
    		'favicon' => 'tumblr.png',
    		'url' => 'http://www.tumblr.com/share?v=3&u=PERMALINK&t=TITLE&s=EXCERPT',
    	),

    I faced the same issue for the other URLs also, did the same.

    Just removed the &amp with semicolon and place the & only.

    It works.

    I made the changes above and it worked as well. Thanks! 🙂

    I added the following line to sociable.php, just after line 637:

    $url = str_replace('&amp ;', '&', $url);

    This fixed both my Digg and LinkedIn links as far as I can tell.

    Edit: the forum doesn’t want to take my &amp ; bit. Just remove the space between &amp and ; and the code snippet above is correct.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: Sociable] Problem posting to digg’ is closed to new replies.
Skip to toolbar