Support » Plugins » [Plugin: Sociable] Patch to support

  • Hey,
    I’m here to share some code I wrote today. Sociable only supports at the moment. I wanted to use an url shortener like, so I hacked into the core of the plugin to support more url shortener. At the moment, I support with an API key. Feel free to request more url shorteners. You can find the patch and the new files there.

Viewing 13 replies - 1 through 13 (of 13 total)
  • I downloaded the zip file, but unfortunately the file is empty, zero length.

    Thank you to report this bug. This is really strange because on the FTP the file is fine, but when I download it the bitly.php is empty :/.
    Anyway, I put the file outside from wordpress folder and it work. Get it here.

    thank you, it works great now!

    Hi, I implemented these files (copied them into the sociable dir), and then edited the sociable settings to select and put in my username and API key. However, nothing is any different on the blog…when I click on the Twitter icon for example, the URL is the same and does not shorten. Am I missing a step?

    Actually, nevermind, I got it to show up on the page…BUT, when I click the link and it takes me to the page to translate the link, it just displays a blank page and doesn’t ever translate/resolve to the social network site. Here’s a sample:

    I can’t get this patch to work. Has anyone been able to get it to work? I have the same issues as hearmegrrl with the long links that lead back to an error page on my blog.

    @isra17 – Great patch! Worked like a charm
    @archetypemkt – verify that you did the following:
    1. copy the contents of the .zip file into the sociable folder
    2. verify the sociable plugin is activated
    3. from the wp dashboard: options > sociable make sure that:
    a) Url shortener: as radio button checked
    b) login: enter your username
    c) API Key: enter your API Key
    4. Save changes



    This worked great for me, thanks! One question. Is there a way to add “Im reading…” before the actual post name and shortened URL that results in the tweet? If so, where would I add that? Im PHP challenged…

    If this isnt working you should make sure that you followed Baden step. I updated the patch today because I just found out that wordpress where using its own custom magic_quote function and when you were trying to use ‘,” or \ in your title they were escaped. Only has changed.

    @apronstringsaflutter – You can ‘hack’ through sociable.php in sociable plugin folder and change line 540 into something like
    'url' => '',

    I hope this might help you

    Patch works just fine with the exception of one detail – while URLs are shortened, neither Facebook, nor Delicious fetches info like post title. As a result, when sharing through Facebook, URL is used as both URL and title, the same goes for Delicious.

    Twitter works great, with certain changes I made:
    'url' => '|%20BLOGNAME|%20PERMALINK',

    On the other hand, similar changes made to Facebook do not work, post title and blog name are not posted to Facebook:
    'url' => '|%20BLOGNAME',

    It all worked without the patch.

    I didnt change anything in the url list, but you should try to replace the ‘&’ by ‘&’ like others URL.
    Original version (note the &)'url' => '',
    this should look like
    'url' => '|%20BLOGNAME',
    hope this help

    Edit: Nevermind, look like & amp; are converted to & by wordpress.

    Edit 2: Found why it happens. This is dumb (I’m using ‘t’ to pass the link throught the script but page like facebook use ‘t’ too so its not working well. I will fix it asap.

    I did some change. I’m not using facebook tho, so I can’t test if it work now, but I think it should. New version here :

    Great, I confirm Facebook, Twitter and Delicious working just fine. Thanks a lot for a quick reaction!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Sociable] Patch to support’ is closed to new replies.