Support » Plugin: Sociable » [Plugin: Sociable] 404s Being Generated

Viewing 15 replies - 1 through 15 (of 19 total)
  • Well, here’s a troubling update on this 404 issue. I deactivated the Sociable plugin, AND its files have been deleted. But the following 404s (including a new 404) are STILL being generated whenever a web page is visited:

    I just noticed there’s a double “//” in the above URL. Is that the reason for the 404 in that case?


    So I take this to mean that some WordPress file(s) (outside the Sociable plugin) were modified by the Sociable installation?

    ADDITIONALLY, whatever WordPress file(s) the Sociable plugin has modified seems to be interfering with a replacement social-icon plugin working correctly.

    This is VERY frustrating. Does anyone have a CLUE how to fix this issue?


    Just noticed these problems myself. I hope the author replies.

    Plugin Contributor sociable


    Hi Davidjacques,

    We read and appreciate all the messages, we are releasing new versions with improvements.

    This particular bug is being seen for the new version 4.1.9

    About this issue we are going to be updated in this thread.


    Greetings, Davidjacques —

    As I stated above, I deactivated and deleted the plugin’s files, but am still receiving the 404s. To solve this issue:

    1) Will it be necessary for me to restore my entire site’s WordPress files? Or…

    2) Will a future update truly solve the 404 problem?

    I’m not sure whether I should go ahead an attempt the restore process (I’ve not done that before), or whether it’s best to wait for a future update.

    Thanks for any input you can provide on this.


    This has been an increasingly frequent issue that I’ve written to the developers about at least twice in the past couple of months.

    There are a number of problems which I’ve identified and I have fixed them on some of my sites. Each subsequent revision I’ve hoped they would fix the problem, but instead there’s simply been more of the problems.

    For instance, the issue DebNCgal wrote about initially is caused by the incorrect use of a leading slash following the “SOCIABLE_HTTP_PATH” variable in the file plugins/sociable/sociable.php.

    But there are numerous new instances of incorrectly stated root paths to images, such as: src="/wp-content/plugins/sociable/images/skyphoto.png" in the file plugins/sociable/includes/class-sociable_Admin_Options.php.

    Other issues include a missing “http” in the src URL for the Facebook iframe in the file plugins/sociable/sociable.php.

    I love this plugin and hope the developers are able to find and fix all these problems. I’m not PHP expert and I’m able to find many of them, so they should be able to as well.

    Hope this helps a few people.

    Plugin Contributor sociable


    DebNCgal, jadeburn, Davidjacques,

    can you give us the urls of your blogs please?


    I’ve completely disabled sociable until it’s fixed. My error logs were getting too full. So, my URLs don’t matter.

    FYI, some of the problems I’ve experienced (definitely not all) result from the fact that many of my installations are not in the root, so the URLs are domain/blog and the errors are being caused by sociable incorrectly assuming the installation is in the root.

    As a result, I’m seeing errors like domain/wp-content because the path should actually be domain/blog/wp-content.

    See my original post above for some of the instances of errors in the code. There are other posts in this forum about the same problem in sociable.css

    Thanks so much. My blog is

    There are several things happening with my site that appear to be related to the latest installation of the Sociable plugin, plus I’ve noticed that the behavior slightly varies between browsers — even when the browser caches have been cleared.

    For instance, the following is occurring with FIREFOX:

    After I deactivated and deleted the Sociable files, I turned on Pretty Link Pro’s social network icons. Please note that the social network icons that are currently showing (in Firefox) at the bottom of posts on the HOME PAGE are from the Pretty Link Pro plugin. But, for some reason, the SECOND post on my home page (titled “Remembering the Fallen”) does NOT display the icons.

    The weird thing is that once I noticed the Pretty Link Pro icons were not showing on the second post on the home page, and couldn’t figure out why not, I turned them OFF — and they’re STILL turned off. Yet they continue to show up on the home page (when viewed in Firefox).

    The next scenario is that when you click on the title of any post on the home page and open the single-page version, the Pretty Link Pro social icons do NOT show up at the bottom of the posts.

    HOWEVER, in Firefox I see the phrase, “Share This Article!” showing at the end of the post, just above the post-meta tags. That phrase is my customized phrase that I’d made in the Sociable plugin, and it’s showing up, even though the Sociable files have been deleted.

    (I don’t believe it’s feasible for me to contact the developer of the Pretty Link Pro icons about the icons showing up inconsistently on the home page until the Sociable plugin issue has been addressed. As I suspect that somehow the Sociable plugin may be to blame for the problem.)

    Now, in Safari, I see NO Pretty Link Pro social icons on the home page posts; however, the Sociable plugin’s “Share This Article!” phrase DOES show at the bottom of the single-page version of posts.

    And here’s a third scenario: From Safari on my iPhone, I get still another iteration. Home page view – No Pretty Link Pro icons show on posts. The single-page version of any of the posts DOES show the Pretty Link Pro icons at the bottom of the posts — except not for the second post on the home page (titled “Remembering the Fallen”). But NONE of the single-page versions includes the phrase, “Share This Article!” that I had set up in the Sociable plugin.

    A fourth scenario: Using the Skyfire browser on the iPhone again does NOT show the Pretty Link Pro icons on the home page posts, but it shows the Pretty Link Pros but NOT the “Share This Article!” phrase on the single-page posts. But, oddly, the single-page version of that second post on the home page (“Remembering the Fallen”) shows NO Pretty Link Pro icons, BUT it does show the “Share This Article!” phrase.

    There may be something I’ve overlooked, but hopefully this has given you enough to go on, as far as the trouble points and the inconsistencies. I’m sorry if this is confusing….

    FYI: 404s are not generated on home page views. They only occur when the single-page version of a post is visited. Currently, visits to any of my single-post pages generate anywhere from four to eight 404s.

    Please let me know if you have any other questions. Thanks for your assistance.

    To further cloud the issue, I just went again to the my home page using Firefox. The PLP icons do NOT show on the home-page posts in Firefox, as they did just a short while ago. However, the “Share This Article!” phrase IS showing on the single-page post views.


    I only noticed the 404 error on more.png. I just copied the image to the folder where it was missing. I manually put the sociable code in my templates, so I didn’t find code leftovers after removing. I certainly hope that the plugin doesn’t go modify your pages! If it does then I hope it cleans up after itself on uninstall…

    It’s sad that these errors happen. It is (or was) a fairly good plugin, but the bad URL errors, bad formatting, etc., really leave a bad impression on attention paid to, and quality of, coding.

    Davidjacques, yes, the more.png image has been missing from one of the directories for several versions now. I also simply copied that image from another directory.

    However, with this latest version, I have encountered multiple 404s, besides the more.png image; and I don’t know how to correct those URLs. And worse — the 404s are still occurring even though the plugin has been deactivated and the files have been deleted. This is unacceptable.

    Sorry to hear that and sorry I can’t help. Seems Sociable has messed with your files or database and didn’t clean after itself after uninstall. I’d also say that is unacceptable.

    May I add that Sociable calls multiple CSS and JS files (more than necessary), making pages load slower, ***even on pages where Sociable is not even called***. You might all want to check that too.

    I’d suggest to the developer
    1 – Check your URLs
    2 – Don’t load your CSS and Javascripts on pages where Sociable is not called
    3 – Make a clean uninstall

    For the developers, here’s a list of sociable’s identified errors:

    incorrect use of a leading slash following the "SOCIABLE_HTTP_PATH" variable in the file plugins/sociable/sociable.php.

    incorrectly stated root paths to images, such as: src="/wp-content/plugins/sociable/images/skyphoto.png" in the file plugins/sociable/includes/class-sociable_Admin_Options.php

    missing "http" in the src URL for the Facebook iframe in the file plugins/sociable/sociable.php

    incorrect redirect URL for function sociable_2_remove() in the file plugins/sociable/sociable.php

    incorrectly stated root paths to images in sociable/css/sociable.css

    Excellent contribution, jadeburn. Thank you.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: Sociable] 404s Being Generated’ is closed to new replies.