Support » Plugin: Sniplets » [Plugin: Sniplets] breaking admin in WP3.3

  • I love this plugin. But having problems now with WP3.3.

    With this plugin active the hover-overs in the menu don’t work, the image uploader doesn’t work (doesn’t popup), and the screen options doesn’t work.

    I’ve also had problems trying to save new Sniplets, and export/import.

    Thanks for looking into this.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Noticed the devlopers site says “This plugin is no longer actively maintained”.

    Looking for a good alternative…may try global-content-blocks.

    I’m in the same boat. I’ve been nervous about this plugin, as it is entrenched in my site.I held off on upgrading, though, to see if anyone else had problems….

    So, based on the problems I see, I am messing with a workaround. I haven’t gone all the way through this yet, but here’s what I am thinking.

    I installed the shortcode exec php plugin. It will do php and html like sniplets. It seems to work when entered in custom fields and pulled up in the post php. (I use a custom posts plugin from before custom posts were part of the core, and i use custom fields as a CMS.)

    I dumped the sniplets table from phpmyadmin, and put it into the word 2000 format. It keeps the data intact best for copying and pasting.

    I exported a shortcode from the exec php admin page, and then pasted the content from the table into the xml file and imported it. It worked, so I am thinking of trying to concatenate the heck out of the code in excel to eliminate the cutting and pasting.

    now, the part I haven’t tested is that I am going to try using ‘sniplet’ as part of my shortcode name (added when I do the concatenation mentioned above). The shortcode exec php plugin works with two words with a space for the name, so i am thinking if I disable the sniplet plugin, the existing commands would not need to be changed on all the posts. Does that logic seem to hold?

    Any thoughts on this late-night ramble?

    A simple workaround I could find: if you use another editor such as Dean’s FCK editor , by example, then sniplet (ie media uploader) works normally……

    Since this plugin is no longer maintained I’ve successfully migrated over to using Shortcodes UI plugin. It works great.

    @jt70: Shortcodes UI supports similar naming conventions, so I suppose if you had too many Sniplets to copy/paste then you could do a table insert into Shortcodes UI similar to what you have mentioned.

    It would still be nice if someone took over development of Sniplets.


    I have just found this post as I am looking for an alternative for Sniplets as I am having similar media uploader issues after upgrading to 3.3.1

    So Shortcodes UI & Deans FCK editors works… I will give them a try thanks!


    When activating this plugin on WP 3.3.1, the follow message is displayed…

    The plugin generated 979 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    …and all javascript seems to break

    Alternative to SNIPLETS…

    Sniplets was a great plugin while it lasted. Here is what I am using as a work-around to give similar functionality of blocks of mixed html and php. First install the “Allow PHP in posts and pages” plugin. Then install “dcoda boilerplate” plugin. use the “plates” the way you would have used sniplets, and if you need to embed snippets of php in the code of your “plates,” surround them with the before and after shortcodes: [php] and [/php]. The php appears to execute on the page or post that calls the boilerplate. So far all my sniplets-reconstructed-as-boilerplates work fine.

    Thanks Rivers

    This was looking promising, I installed the Allow PHP plugin, then the dcoda but i get the following error:

    Fatal error: Class ‘boilerplate_default’ not found in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\wp-content\plugins\wp-boilerplate\library\base\application.php on line 118

    Tis happens if I install through the Network Admin or Putting it straight on the server…

    Any ideas?


    In addition to the ‘Shortcodes UI’ plugin which I mentioned above that works well as a replacement for Sniplets, another possible alternative is ’embedit-pro’ (free even though says pro).

    So either of these should do the job:

    Shortcodes UI


    Shortcodes UL seems to working OK so far, the icon doen’t appear in the wysiwyg editor but I can live with that!




    Thanks SiteSubscribe for mentioning “Shortcodes UI”. Works like a charm. But I had several hundred posts with Sniplets in them so all I did was recreate my Sniplets in ShortCodes UI as follows:

    Sniplet name: “mysnipletname”
    Shortcodes UI name: “sniplet_mysnipletname”

    I kept the name “sniplet” in my Shortcodes UI names so there would be no confusion with any other short codes and I’d know what the short code is for.

    Then I used Search Regex to do a global search and replace to change the sniplet short code syntax to the shortcodes UI syntax:

    Search for: “sniplet mysnipletname”
    Replace with: “sniplet_mysnipletname”.

    Done! No fuss, no mess.



    I’ve been using Shortcodes UI for about 6 months now and it works great, and is actively developed.

    Plus it has some nice additional features like replacing content from the editor into your snippet of code. And it accepts PHP/javascript. Overall a great plugin.

    @nanowisdoms: glad the search/replace with Shortcodes UI worked for you.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: Sniplets] breaking admin in WP3.3’ is closed to new replies.