Support » Plugin: Snapshot Backup » [Plugin: Snapshot Backup] Upgrade to 2.0 and new installation of 2.0 error

  • Snapshot 2.0 installs and activates without any problems but when I go to any of the admin options I get the following errors:

    Warning: include(/path/wp-content/plugins/snapshot-backup/includes/snapshot-functions.php) [function.include]: failed to open stream: No such file or directory in /path/wp-content/plugins/snapshot-backup/snapshot-backup.php on line 215

    Warning: include() [function.include]: Failed opening ‘/path/wp-content/plugins/snapshot-backup/includes/snapshot-functions.php’ for inclusion (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /path/wp-content/plugins/snapshot-backup/snapshot-backup.php on line 215

    Fatal error: Call to undefined function snapshot_header() in /path/wp-content/plugins/snapshot-backup/snapshot-backup.php on line 216

    Earlier version of Snapshot was working fine for me.

    Please help.

    Thank you.

    http://wordpress.org/extend/plugins/snapshot-backup/

Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Author Jay Versluis

    (@versluis)

    I do apologise,

    this happened because some files were not copied into the WordPress repository.

    Hence I’ve just released 2.0.1 – which is exactly the same version as 2.0 but gives everyone the possibility to upgrade to a fully working version.

    Hello Jay,

    Getting a new error:

    Warning: Missing argument 2 for snapshot_header(), called in /path/wp-content/plugins/snapshot-backup/snapshot-backup.php on line 274 and defined in /path/wp-content/plugins/snapshot-backup/includes/snapshot-functions.php on line 11

    Plugin Author Jay Versluis

    (@versluis)

    Crazy stuff…

    It’s the function that displays the header picture and headline, should only take one argument. Perhaps something went wrong with the upgrade locally?

    I’d suggest to remove the plugin, then add it again from the repository. Let me know if that works.

    Hi,

    This morning, my hosts suspended my website owing to “multiple simultaneous backups” that were impeding other clients’ abilities to run their sites. They asked me to disable Snapshot Backup, which I’ve now done so as to get my site back up. Obviously, this is not a good solution for me, as I now don’t have backups running. One thing I noticed before uninstalling was that I had the same error message as anjaan79 describes in his most recent reply above. Are these things connected? In any case, what can I do to ensure this problem is not repeated?

    Thanks!

    Removed and reinstalled. Still get the same error.

    However, the plugin works fine. Creates backup without any problem.

    Plugin Author Jay Versluis

    (@versluis)

    That’s not good – I agree! Who are you hosting with? I have noticed that the automation impedes a single website’s performance during the backup itself, so when you’re testing a backup every 2mins then is noticeable (and usually not required for production sites). If you create a backup once a day there should be no problem with other people’s websites on a server.

    Anjaan’s error doesn’t show on my system so I’m pretty much tapping and guessing in the dark on how to fix it. Glad the backup creation works either way. Does the error show in every menu?

    Yep it shows in every menu.

    Hi Jay,

    Thanks for the speedy response. I’m hosting with Hostpapa. Was pretty upset when their e-mail came this morning, as a number of potential clients are trying to look at my work today. I actually had automation disabled. I only wanted to backup my site every now and then, particularly before WP upgrades. This is why I’m confused. Yes, the error appears on every page, and it wasn’t there yesterday (before I upgraded to 2.0.1. FYI I have a pretty huge site, some 10 Gb. I’m a photographer, and my images tend to be around 15-25 Mb each. The eCommerce solution I use picks these up from my server when a sale comes through, so the client gets them full size if required.

    Robin

    Plugin Author Jay Versluis

    (@versluis)

    Thanks for letting me know, I think the problem theis the size of your site. It takes quite some time to copy 10GB over.

    Have you used Version 1.6 before, and did that work for you? Also, are you using the plugin with the FTP option or are you using it for local backups?

    I’m really sorry this has happened to you and I hope Hostpapa will bring you back online.

    I’ve not used 1.6 before. Should I use that instead? I actually installed your plugin for the first time only a couple of days ago. Hostpapa re-activated my site on the condition that I disable your plugin. Not a solution I appreciated! I’m using the FTP option.

    Plugin Author Jay Versluis

    (@versluis)

    Guys,

    I took a good hard look at the code and have found the problem with the header error message. I’ve just released 2.0.2 which *should* alleviate this. Please let me know if it does as my server doesn’t show the error.

    Thanks for letting me know about your issues by the way, it’s much appreciated! Your feedback makes Snapshot Backup better 😉

    Thanks, Jay. Will do. Do you think this will stop the multiple simultaneous backups that Hostpapa said were happening?

    PS I’m not seeing an option to upgrade.

    Plugin Author Jay Versluis

    (@versluis)

    It takes a few minutes to show on WordPress. The upgrade only gets rid of the error message. The earlier versions only had the manual option, that was the only difference.

    I’m a bit puzzled by Hostpapa’s multiple backups theory.

    Scenarios that could create multilevel backups are: when you hit the Create Backup button, the plugin executed a TAR command on the server. Say you were in two browser windows of your back end at once, you could theoretically press the button once in each window, which would lead to the backup being created twice at the same time. I’m sure you didn’t do this though. Or you could create another backup while one is till in progress. Or the automation would create one in the background while you hit the button to create a backup manually.

    They may be concerned that during a backup Snapshot may hog server resources and understandably they want to protect themselves against this. I’ll have a think how I can throttle how the plugin does what it does and will let you know. It’ll be another challenge….

    Thanks Jay. I often do have multiple backend tabs open, but had not even looked at Snapshot (except to upgrade) today. Moreover, I had automation off. So it seems odd. Still waiting for 2.0.2 to appear… . If my hosts are worried about resources, why do they promise unlimited bandwidth? (Assuming, from my limited knowledge, that this is the same thing.)

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Plugin: Snapshot Backup] Upgrade to 2.0 and new installation of 2.0 error’ is closed to new replies.