WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Snap My Roll] [Plugin:SNap My Roll]

[Resolved] [Plugin: Snap My Roll] [Plugin:SNap My Roll]

  • hi there,
    when using the plugin with the widget it came, I get this error on my site:

    Warning: imagecreatefrompng(exceeded.png) [function.imagecreatefrompng]: failed to open stream: No such file or directory in /var/www/web6/web/wordpress/wp-content/plugins/snap-my-roll/snap-my-roll.php on line 62

    any ideas what could be wrong? line 62 read:

    $exceeded = imagecreatefrompng (“exceeded.png”);

    http://wordpress.org/extend/plugins/snap-my-roll/

Viewing 15 replies - 1 through 15 (of 32 total)
  • exceeded.png is an image file used to filter out the “error” image returned by websnapr.com

    The file is included in the last version of the plugin and should be kept in the smae directory than the plugin script file “snap-my-roll/snap-my-roll.php”

    Could you check if this file exist ?

    If not simply reinstall the last version of the plugin and make sure that the image file is in the directory.

    yes, exceeded.png is in the right folder.

    BUt I am using wordpress installed into a subdirectory, so there is an additional wordpress directory in my path.

    So maybe the path is hardcoded somewhere?

    The path is dynamically generated.

    The version 0.9 uses 2 versions of the exceeded file. Could you give it a try ?

    sorry, didn’t see your reply.
    now I am using your latest version the error is gone, but the widget isn’t displaying anything. see here: http://pacura.ru/ right above the links in the sidebar is your widget, but you have to check the source code, all you will find is an empty div, 🙁 I have no clue whats wrong…

    Hi Ovidiu, there was indeed a display problem with WP 2.6.1. This is solved with WP 2.6.2.
    Upgrade your blog to 2.6.2, reactivate the plugin and it should work.

    updated to 2.62 your plugin 1.01 but still nothing shows up. can you check at the link I gave above?

    Accroding to what I see you don’t have created a link yet, the table doesn’t exist.

    You should add some links to your blog (build a blog roll) before using the widget

    WordPress database error: [Table 'web6db2.wp_links' doesn't exist]
    SELECT wp_links.link_name, wp_links.link_url FROM wp_links WHERE link_visible = 'Y'

    thats weird I didn’t notice that.
    Anyway I have links, as you can see there is a links widget on my site 🙂 exactly below your widget.

    is wp_ hardcoded somewhere in your plugin? I have another db prefix…

    Thanks Ovidiu for reporting this, indeed the database prefix was hardcoded.

    I have changed the plugin and create a 1.0.2 version that fixes this issue.

    Let me know if your problem is solved.

    hmm. no errors. yet no snapshots. maybe have to wait?

    : imagepng() [function.imagepng]: Unable to open 'wp-content/uploads/http___magister_co_za_t.png' for writing: No such file or directory in /var/www/web6/web/wordpress/wp-content/plugins/snap-my-roll/snap-my-roll.php on line 82
    # Magister
    »Magister
    
    Warning:

    It seems your plugin is using: $js_url = get_option(‘siteurl’) . ‘/wp-content/plugins/’. dirname( plugin_basename(__FILE__)) . ‘/js/’;

    to detect where to upload to and I am not sure if that will work with my installation as my blog uses:

    WordPress address (URL): http://pacura.ru/wordpress
    Blog address (URL): http://pacura.ru

    it is installed into a subdirectory. so I am not sure if siteurl will get you the right path, there was something like blogurl? well anyway these are just guesses as I am no programmer 🙂

    Ok I’ll check and keep you posted

    The plugin uses the upload_path option to determine where to store the snapshots. This option is set into your blog options. Could you have a look at the value of it and post it here ?

    Your wordpress address is represented by the siteurl option.
    I never use the blog adress also known as the home

    I have solved the title problem in the 1.0.3 version

    upload path is wp-content/uploads the other settings I have already psoted above.

    listen, if you are willing to help out I could provide you an admin login for a day or two.

    with your latest version 1.03 I get this error on my frontpage:

    <b>Fatal error</b>:  Call to undefined function error() in <b>/var/www/web6/web/wordpress/wp-content/plugins/snap-my-roll/snap-my-roll.php</b> on line <b>67</b><br />

    here are the lines in question (66-68):

    if (!is_writable($directory . '/'))
    			error("WordPress upload directory is not writable");
    		//create error image to compare them with file downloaded
Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘[Resolved] [Plugin: Snap My Roll] [Plugin:SNap My Roll]’ is closed to new replies.