Support » Plugin: Smilies Themer Toolbar » [Plugin: Smilies Themer Toolbar] Not Compatible With jQuery v.1.6.4

  • Xaliber

    (@xaliber)


    This plugin is not compatible with jQuery v1.6.4.

    The latest jQuery version that works is jQuery v1.4.4 (which is bundled with WordPress 3.1.4, AFAIK). When I updated the jQuery to v1.6.4, it stops working.

    Any chance to make it compatible?

    Here is the Javascript included in this plugin:

    /* <![CDATA[ */
    (function($) {
    	/* OnClick action */
    	$("#smilies_toolbar img").click(function() {
    		var text = $(this).attr('alt');
    		/* get an html escaped version of the text: */
    		tempdiv = $('<div/>');
    		text = tempdiv.text(text).html();
    		tempdiv.remove(); // Free up memory
    		var commentbox = $("form[action$=wp-comments.php] textarea:visible");
    		if (!commentbox.length) return;
    		commentbox.insertAtCaret(text);
    	});
    	$("#smilies_toolbar img").css('cursor', 'pointer');
    })(jQuery);
    /* ]]> */

    http://wordpress.org/extend/plugins/smilies-themer-toolbar/

Viewing 1 replies (of 1 total)
  • I changed the line:

    var commentbox = $("form[action$=wp-comments.php] textarea:visible");

    to:

    var commentbox = $("#commentform textarea:visible");

    … and that work well on my wordpress, but I have no idea if this will work on every installation and with every theme.

    Hope it helps anyway.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Smilies Themer Toolbar] Not Compatible With jQuery v.1.6.4’ is closed to new replies.