WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Smart YouTube] version 2.1; html code problem

[Plugin: Smart YouTube] version 2.1; html code problem

  • installed the newest version (2.1.1) just now, it appears the html-code is broken to some extend on line 416;
    * object tag isn’t closed
    * ugly embed-code sneaked back in (resulting in broken xhtml-compliance)

    i ended up commenting line 416 and uncommenting 419, in which the 2 problems above do not occur.

Viewing 11 replies - 1 through 11 (of 11 total)
  • 2.1.2 fixes the object tag, but the “ugly embed code” is youtube’s own and I included it for compatibility with iphone. will try to sort it out to have best of both worlds.

    if embed is absolutely necessary for iphone, it would be nice if blog-owners could switch iphone+embed off/on (or xhtml compliancy off/on) in the admin panel?

    This is causing issues with IE6.

    With 2.1.x, I get an “Internet Explorer Cannot Open the Internet Site- Operation Aborted” Error. It does, however, work just fine with FF and Opera.

    I had to revert to 2.0.1 for now.

    This is an epitome a well coded program, simple yet intuitive and highly functional. These are the kind of programmers who get us closer to telepathic programming! 🙂

    I think this is also causing problems for my z-index and priority over iFrames.

    I have iFrames inserted before the object & embed tags, yet the youtube video is placed above my iframe that opens on the center of the screen. If this is unrelated, please advise where I could fix this. Thanks!

    The new versio address this issues and produces xHTML valid code while remaining compatible with iPhone.

    just saw there’s a 2.3 in which you can choose to turn off xhtml-compliancy because of compatibility issues? could you elaborate which browsers/ feedreaders have issues with the xhtml-valid version?

    Please, can anyone help me ……..

    I upgraded to 2.3.2 and the YouTube videos NOT work on my regular site
    http://www.afacereonline.ro

    Does anyone know if you can embed YouTube videos using this plugin (or any other method for that matter) that *both* play in iPhone Safari and validate as xhtml code?

    Can’t seem to be able to do both simultaneously!

    I am using Smart-YouTube and following the instructions to use the httpv. I also have tried several different settings both with xhtml validation and without. No matter what I do my feed will not validate! I get the following error:

    line 131, column 0: content:encoded should not contain object tag

    What am I doing wrong? How do I embed a you tube video without breaking my validation?

    Is there no one out there that can help???

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: Smart YouTube] version 2.1; html code problem’ is closed to new replies.