WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Smart YouTube] drop down menus hidden behind youtube

[Plugin: Smart YouTube] drop down menus hidden behind youtube

  • My drop-down menus are hidden behind the YouTube embed. It can not be fixed with z-index, and although I see wmode transparent in the changelog and resolved forum post, this is does not appear in my code. Problem persists, and upon inspecting html the wmode parameter is not there.

Viewing 8 replies - 1 through 8 (of 8 total)
  • *bump*

    I still can’t figure this one out.

    I have the same problem, I use the latest version of Smart youtube.

    I actually found a solution to this problem with smart youtube.

    1. Go to plugins menu i wordpress.
    2. Press edit on smart youtube plugin.
    3. On your right of the screen you will see the headline “plugin files”
    4. Press on the file: smart-youtube/smartyoutube.class.php.
    5. Press Ctrl+F on your keyboard and search for: wmode
    You will find something like

    <param name=”wmode” value=”transparent”>

    Delete that and replace with:
    <param name=”wmode” value=”opaque”>
    6. It should look like this when you’re done

    <span class=”youtube”>
    <object type=”application/x-shockwave-flash” width=”$width” height=”$height” data=”$video_url”>
    <param name=”movie” value=”$video_url” />
    <param name=”allowFullScreen” value=”true” />
    <param name=”wmode” value=”opaque”>
    </object>

    7. Now, search for: embed src
    You will find something like

    <embed src=”$video_url” type=”application/x-shockwave-flash” allowfullscreen=”true” allowscriptaccess=”always” width=”$width” height=”$height”></embed>

    Right after: x-shockwave-flash”
    Add the line: wmode=”opaque”

    8. It should look like this when you are done

    <embed src=”$video_url” type=”application/x-shockwave-flash” wmode=”opaque” allowfullscreen=”true” allowscriptaccess=”always” width=”$width” height=”$height”></embed>

    Now you’re done, just press on the update file button on the bottom of your screen.

    Just ask if you have any questions or if my guide doesn’t work.

    Confirmed, works great…thanks Raibzer!

    Sounds great, and I’m going to give it a try. BUT, will changes like this get overwritten when the next version of Smart Youtube comes out? Just wondering…

    Zoinks:
    To be honest I haven’t tried to update Smart youtube so I don’t know. I’m trying to avoid it 😉
    If you give it a try don’t forget to post and tell us how it went.

    Hey So I’m using version 3.8.6 of Smart Tube and it’s jumping around like crazy on Ipod safari and it’s also covering up my drop down menu.

    It’s also covering the drop down menu on Internet Explorer.

    I tried to adjust the code as outlined although I see it’s changed since this solution was posted. I understand flash embedding ok so I made the changes and still nothing.

    I’ve tried the forums for smart tube as well but was hoping there may be a faster response here.

    Any ideas are appreciated on how to fix this issue.
    Cheers

    Thanks raibzer – The one step you missed was unchecking the “Use IFRAME embed code (recommended)” box in the smart tube settings.

    I also took it one step further and made it easier for my clients to add videos using a custom short code.

    //creates short code youtube videos
    function smokinvid($atts, $content = null) {
    extract(shortcode_atts(array(‘link’ => ‘#’), $atts));
    return ‘httpv://www.youtube.com/watch?v=’.$content.” ;
    }
    add_shortcode(‘smokinvid’, ‘smokinvid’);

    Here’s the short code were they only have to enter the video id.

    [smokinvid]mPbQ8pEXzbE[/smokinvid]

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Smart YouTube] drop down menus hidden behind youtube’ is closed to new replies.