[resolved] Can't get it to work (6 posts)

  1. peredur
    Posted 3 years ago #

    Default (local) WordPress installation.

    Using "Sample Page" to test the plugin.

    Created a slideshow as follows:

    Permalink: http://localhost/wordpress/slideshow/book-test/
    ID: 5 (according to the plugin)

    Added 7 images and checked they appeared in the slideshow. They do.

    Added the following short code to the page (copied from the Slideshow page):

    [slideshow_deploy id=5]

    Nothing shows on the page. If I try to view the slideshow from the Slideshow editor page, I just get a 404.

    Tried trashing and recreating several times. Never worked.

    Any help would be appreciated.




  2. peredur
    Posted 3 years ago #

    Sorry to follow up my own post. I've got some new information.

    The 404 was being generated by what appears to be a bug in WP3.4 that arises when permalinks are changed from their default value in Settings --> Permalinks.

    So I've done several things. Firstly I've completely removed WP and its database tables and reinstalled it. Having done that, I've left it in the default state with the default permalink settings. Then I've reinstalled Slideshow from scratch, and recreated the media library with my seven images.

    Next I create a Slideshow. Even though it's a completely virgin install (including deleting and recreating all the database tables), for some reason the id is now given as 11. The permalink for the slideshow is showing as http://localhost/wordpress/?slideshow-book-test

    If I try to view the slideshow from the slideshow admin page (after updating the page) I get the WP error page:

    This is somewhat embarrassing, isn’t it?

    It seems we can’t find what you’re looking for. Perhaps searching, or one of the links below, can help.

    The URL it's trying to display is:


    Entering the shortcode [slideshow_deploy id=11] in the sample page has no effect at all on the output of the page.


  3. Stefan Boonstra
    Plugin Author

    Posted 3 years ago #

    Hi PAE,

    I'm sorry for this inconvenience, the jQuery library wasn't properly called in version 1.2.1 of the plugin. If you download the plugin again, a slideshow should be visible where ever you've placed the code for it.

    The 404 you were getting when trying to visit the slideshow from the admin page is perfectly normal, a slideshow is not a public post type and therefore can't be shown as a preview on its permalink.

    I'm going to see if I can dispose of the preview/permalink because I see how getting a 404 is confusing.

    I hope I've answered your question.


  4. Stefan Boonstra
    Plugin Author

    Posted 3 years ago #

    - The preview button has been removed in the upcoming 1.3.0 release.

  5. peredur
    Posted 3 years ago #

    Yes it does (answer the question). Thanks.

    I do have another problem though, in that half the image is covered by a grey background. I can send you a screen dump if you provide me with an email address.

    Perhaps you'd rather I opened a new thread for this? If so, please just let me know.



  6. Stefan Boonstra
    Plugin Author

    Posted 3 years ago #

    I can't think of anything within the plugin causing a grey background, currently (1.2.1) only the color black is used. A screenshot would indeed be helpful, my e-mail address is wordpress@stefanboonstra.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Slideshow
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.