Support » Plugin: SlickQuiz » [Plugin: SlickQuiz] Quiz content not displaying, but labels are

  • Resolved Vighpyr

    (@vighpyr)


    I installed the plugin, activated it and it seems to work fine as far as creating a new quiz. When I put “[slickquiz id=X]” (I replaced the “X” with the number of the quiz I created) and view the page, all I get is:

    THE NAME OF THE QUIZ

    Get Started
    Your Score:

    Your Ranking:

    That’s it. Any idea what I’m doing wrong?

    Here is the info from the Developer’s Console when I view the page:

    <em>GET http://funfit4life.pcgius.com/wp-content/plugins/css/front.css?ver=3.4.1 404 (Not Found) /?page_id=932:266
    GET http://funfit4life.pcgius.com/wp-content/plugins/slickquiz/css/slickQuiz.css?ver=3.4.1  /?page_id=932:266
    GET http://funfit4life.pcgius.com/wp-content/plugins/slickquiz/js/slickQuiz.js?ver=3.4.1 404 (Not Found) /?page_id=932:266
    Uncaught TypeError: Object [object Object] has no method 'slickQuiz' /?page_id=932:532</em>

    Thanks,
    Michael

    http://wordpress.org/extend/plugins/slickquiz/

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author jewlofthelotus

    (@jewlofthelotus)

    Thanks for the feedback, Michael! It seems the method I’m using to get the plugin path and load resources from that path is outputting the wrong location.

    I just pushed an update with an alternate method of getting the path, so please try downloading the plugin and replacing your current version. (You won’t see the update in your WP app, or a version number change – but it is what’s available on http://wordpress.org/extend/plugins/slickquiz)

    Let me know if you see any change with this!

    Plugin Author jewlofthelotus

    (@jewlofthelotus)

    A new version is up that seems to have fully resolved this issue. Please give it a try and let me know if you’re still having the problem.

    Thanks for your patience and help with this!

    Hey there! I’m having the same problem. The quiz consists of the name (with the apostrophes being escaped out for some reason — Andrew\’s Test Quiz) and

    Get Started
    Your Score:

    Your Ranking:

    The words “Get Started” have the styling of a link (underline appears on hover, for example), but they’re not actually a link. Also, there’s no neat background image for the button.

    I tried uploading the version you linked to above, as well as the one that installs with “Add New” (in case there was a difference). No joy.

    Any ideas? I’m using the latest WP, and I’m happy to give whatever details you need!

    I am using the latest version of WP and of your plugin, but I’m having the same problem.

    If it helps at all here is the markup (I don’t see code anywhere here and this code is static) that I find:

    <div class=”slickQuizWrapper” id=”slickQuiz1″>
    <h2 class=”quizName”></h2>
    <div class=”quizArea”>
    <div class=”quizHeader”>
    <div class=”buttonWrapper”>< a >Get Started!< /a ></div>
    </div>
    </div>
    <div class=”quizResults”>
    <div class=”quizResultsCopy”>
    <h3 class=”quizScore”>Your Score: <span> </span></h3>
    <h3 class=”quizLevel”>Your Ranking: <span> </span></h3>
    </div>
    </div>
    </div>
    <div class=”clear”></div>

    Plugin Author jewlofthelotus

    (@jewlofthelotus)

    Hey @andrewkantor and @ethsaus – could you copy the full source of the page into a pastebin for me? (pastebin.com)

    It seems like the JavaScript is still not loading properly – this could be due to a conflict with another script or just that it’s not loading at all.

    Thanks for your help!

    Here is the url I’m trying to past the code into: http://crossinghistory.com/main/quiz/

    I’ll paste the code later if I can.

    Plugin Author jewlofthelotus

    (@jewlofthelotus)

    @ethsaus – It looks like none of the plugin files are loading at all. Can you verify that the SlickQuiz plugin is activated?

    I do see files for an “ssquiz” – but this is not for SlickQuiz.

    Hmm sorry about that. Not sure why it was deactivated. It is active now.

    You want the code for the entire page? (Well, post?) Okey doke:
    http://pastebin.com/4tS5P8gr

    Here’s something interesting: I have several domains and several site hosted in the same place, off of the same account — meaning the directory structure is the same as the one I’m having trouble with.

    Just for fun, I tried SlickQuiz on another site and it worked perfectly.

    In other words, the site that’s having a problem has a path like

    /public_html/varbuzz/wp-content…

    while the site where SlickQuiz is working has a path of

    /public_html/varwow.com/wp-content…

    So it doesn’t look like it would be a problem with absolute or relative paths. (Then again, I’m no coder.) So I’m thinking maybe it’s a conflict with another plugin. Trouble is, we have a lot, so before I start disabling them I’d like to get an idea of which ones (or which kinds) are likely to cause a problem.

    Thanks for your help with this!

    Plugin Author jewlofthelotus

    (@jewlofthelotus)

    @ethsaus – It looks like there is a problem with another plugin / script on the page that is occurring before the quiz even loads.

    The offender seems to be a missing dialog box – the file with the error is called gsc.js

    Plugin Author jewlofthelotus

    (@jewlofthelotus)

    @andrewkantor – The paths shouldn’t be the issue. Looking at the code you shared, I don’t see any of the javascript resources for the quiz at all. This would suggest to me that the plugin isn’t enabled. And if that was the case, the [slickquiz id=x] shortcode wouldn’t even inject the quiz. So did you manually place the following on the page:


    <div class="slickQuizWrapper" id="slickQuiz1">
    ...
    </div>

    I would try ensuring that the plugin is activated and that you’re using the shortcode on the page.

    Plugin Author jewlofthelotus

    (@jewlofthelotus)

    Actually, @ethsaus – I don’t see the scripts loading on your page either.

    @andrewkantor & @ethsaus – can you verify that your themes contain a call to the wp_footer() method in the footer template:


    <?php
    /* Always have wp_footer() just before the closing </body>
    * tag of your theme, or you will break many plugins, which
    * generally use this hook to reference JavaScript files.
    */

    wp_footer();
    ?>

    More info: http://codex.wordpress.org/Function_Reference/wp_footer

    Honest and for true, it’s activated. Ditto that the shortcode is there. But now I’ll check that wp_footer(); is in place….

    HAHA! It was the wp_footer()!

    W00t! Thank you thank you thank you!

    Plugin Author jewlofthelotus

    (@jewlofthelotus)

    @andrewkantor – Glad to hear that fixed it!

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘[Plugin: SlickQuiz] Quiz content not displaying, but labels are’ is closed to new replies.