Support » Plugin: Skydrv-hotlink » [Plugin: Skydrv-hotlink] Crashed My Site

Viewing 9 replies - 16 through 24 (of 24 total)
  • Plugin Author dpchiesa

    (@dpchiesa)

    Bingo.

    Can you enable mcrypt on your php install?

    I’ll want to make the plugin more resilient in the face of such conditions.

    Not sure how easy it would be to remove the mcrypt() dependency completely. It’s there to prevent external access to the ajax resource.

    I’ll look into it.

    Plugin Author dpchiesa

    (@dpchiesa)

    Ok, I looked into it.

    I have put together a modified version of the plugin that removes the hard dependency on mcrypt.

    Try it and see. It is at the same cheeso url.

    let me know.

    Thread Starter mst2002

    (@mst2002)

    Good news! I installed the modified version and it installed and activated without incident. One question: the Settings > Skydrive-Hotlinks page does not show any content. Is that to be expected?

    Plugin Author dpchiesa

    (@dpchiesa)

    Well that is good news. I’m glad it installed properly and is activated. Next question: is it working?

    As for the admin settings – yes, well. In my efforts to figure out the problem you were encountering, I changed a bunch of things and one of the changes introduced that problem with the amdin form. Not a critical problem, and I had seen it before. Actually the latest zip downloadable from wordpress.org does not have the problem.

    In a moment, I’ll post an update to the cheeso URL which will eliminate that problem as well.

    Plugin Author dpchiesa

    (@dpchiesa)

    Whoops – that was not right. I saw another problem that would occur with the admin form if you do not have mcrypt (as in your case). I just fixed that and posted it to the cheeso url .

    I think / hope that should be the last change.

    Thread Starter mst2002

    (@mst2002)

    That worked and the admin panel is displaying and working.

    One last teeny, tiny issue (sorry!)

    I entered the following to activate the plugin:

    Download

    in this page:

    http://rivetr.com/blog/2012/06/24/sky-drive-trial/

    Sadly, it doesn’t seem to download, but instead to default to a link. I realize that that is the default behavior when the download function fails, so I just want to check and see if my syntax was correct or if it was a plugin issue.

    Plugin Author dpchiesa

    (@dpchiesa)

    One last issue – hah that’s funny. That “one last issue” basically means the plugin isn’t working at all. You are very patient.

    ok, I looked, and the link you are using for your skydrive doc is of a different form than I had seen previously. I’ve modified the pattern-matching so that the plugin will detect the form you are using, as well as the form I have seen in other cases.

    Once again I posted an update to the cheeso URL and I’ll be interested to hear from you if it finally works for you.

    Thread Starter mst2002

    (@mst2002)

    It works!!

    Thank you for being so patient and troubleshooting all of these hitches. Also, I was looking at the source code for the plugin. Thanks for putting in such a lot of safety features (even if one did trip me up!).

    Plugin Author dpchiesa

    (@dpchiesa)

    Oh, I’m glad it works for you finally. Thanks for being persistent.

Viewing 9 replies - 16 through 24 (of 24 total)
  • The topic ‘[Plugin: Skydrv-hotlink] Crashed My Site’ is closed to new replies.