Support » Plugin: Skydrv-hotlink » [Plugin: Skydrv-hotlink] Crashed My Site

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author dpchiesa


    Well that’s unfortunate, I’m sorry to hear you’re having trouble.
    I looked at your site, and I can definitely see that there’s a problem with the skydrive hotlink plugin.

    I don’t know what the problem might be.

    One way to eliminate the plugin is to remove the .php file . This may not require SSH – you could do it via FTP and you could do it via a file explorer if your hoster provides that kind of access.

    the file is …wp-content/plugins/skydrv-hotlink/skydrv-hotlink.php

    I can’t tell what the problem is, but if you want me to look further into it, I can give it a shot.

    Thanks for your reply!

    Sadly, I tried deleting it through an FTP alone. It really does take root level access.

    I will probably sudo in and delete it in the next day or so, but it would be great if you could take a look. I like Skydrive and would really like to use the plugin.

    Plugin Author dpchiesa


    Is it possible to use the wp-admin backend?
    ( )

    Or is that completely hosed too?

    It’s too bad that you don’t have FTP access. That would be the easiest way to yank it.

    Plugin Author dpchiesa


    No, it looks like the administrative piece is hosed, too.
    Wow. I’ve never seen that before.

    I can’t imagine how this plugin could cause such problems.

    It is a bit of a strange error. I have deleted the plugin through SSH and now the site is working normally again.

    Plugin Author dpchiesa


    I’m glad you resolved it. Were you able to look at the files?

    I’m wondering if they were transferred intact, or if one of them was somehow corrupted during install.

    It’s just so unusual. I’ve seen cases where a problem with a plugin causes an unpleasant error message, but never saw a case where it would just flatten the site.

    Not sure if you’re game for it, but the plugin has been updated since the version you tried to install. Consider giving it another shot.

    I tried the file again and, unfortunately, same result. I was wondering whether the issue might be with the scraper. Is that possible?

    Plugin Author dpchiesa


    Well I was able to run the scraper from your site, with no problem.

    It didn’t DO anything, but it didn’t throw an error or freeze or deliver partial output. so that looks ok.

    I requested http://server/wp-content/plugins/skydrv-hotlink/scraper.php and … no problem.

    Doing the similar thing for the skydrv-hotlink.php script, caused a failure.


    When you said you “tried the file again”… did you get the latest version of the skydrv-hotlink download? Maybe the version you have is corrupted.

    Plugin Author dpchiesa


    You can try installing this:

    It’s the latest version.

    MD5: BFABAB84D234D8B6124ABB0199147E81
    SHA1: 96A487F09255C92692F4D51DEA00845E033338F3

    Ah, by “tried the file again” I did mean that I had gotten the latest version of the download.

    I just tried the last plugin you sent. It uploaded just fine, as the others had, but will not activate. Is that intentional?

    Plugin Author dpchiesa


    no, that’s embarassing.

    ok, if you please, download from this location again:

    MD5: 57F860A5C907054CE074C06E9ED7D75B
    SHA1: 3AF0338027FD4EF0BCA8C17F114FF9D2910EBD2D

    it should activate this time. :/

    My site crash when I installed a plugin at one point and I thought about it and I downloaded a duplicate zip file that was named file(1) and it broke the path. So I went into my cpanel and renamed the file and it worked just fine.

    I tried this new download. It did activate, but sadly, no joy (crashed again, in the same fashion). Could the problem be with the host? Could a server configuration be the culprit?

    Plugin Author dpchiesa



    I don’t know, I would have to guess. I’ve done a code inspection but didn’t see any likely culprits.

    Let’s just check some basic things.

    • It uses WordPress features that started with v3.3, so if you are on an older version of WordPress, that could be the cause of it. It actually tests for versions prior to 3.3, and will stop running if it finds that.
    • it uses some features of PHP that started with v5.2. I think possibly v5.2.17, but not certain. If you are on a back-rev of PHP, that could be the problem.
    • it uses PHP CRYPT (BLOWFISH). If you don’t have that it would fail.

    If those basic requirements are satisfied, the next thing I would do, if I were trying to figure this out, is turn on debug mode in WordPress. Do this by modifying the wp-config.php file, which should be in the root of your wordpress installation. There will be a line that looks like:

    define('WP_DEBUG', false);

    Edit that and replace “false” with “true” (no quotes). See also This will not fix anything, but it will provide some additional diagnsotic information that may aid in determnining the problem.

    I just updated the plugin to add more diagnostic messages. Download it again (same cheeso location) and re-try, if you’re game.

    I changed it to debug mode and installed it again. It failed on activation, but it shot out this error message:

    skydrv_hl: definitions
    skydrv_hl: variable init
    skydrv_hl: register hooks
    skydrv_hl: skydrv_hl_activate_fn
    skydrv_hl: is_admin()
    skydrv_hl: operational declarations
    skydrv_hl: ajax setup
    skydrv_hl: script block
    skydrv_hl: ends

    Fatal error: Call to undefined function mcrypt_encrypt() in /var/www/vhosts/ on line 356

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Plugin: Skydrv-hotlink] Crashed My Site’ is closed to new replies.