Support » Plugins and Hacks » [Plugin: Site Template] doesn't work correctly since .4

  • Hi,
    I recently update this plugin and since this time, the plugin doesn’t work anymore.

    I have the radio button on the signup blog form and a blog set as template.

    I used the plugin several time but now I don’t know why but it didn’t do his job anymore.

    Does someone know how to fix, or find the problem?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Can you provide more information about what is not working?

    At the blog creation, the template is not use for the blog creation. It’s seems that it always use default template and not the one I selected.
    What other kind of informations could I provide to help?

    Hummm,
    I don’t know why but it worked today except for menus apparently :
    Warning: Invalid argument supplied for foreach() in C:\wamp\www\WordPress\wp-content\plugins\site-template\site-template.php on line 471

    I didn’t create this blog from nothing.
    Explanation :
    When I wrote the first post, I gone to wp-signup.php without been logged.
    Today, I was on wp-signup.php but i was logged.

    Maybe the trick is somewhere here.

    after few tests, it seams that it works only when creating another blog and not for new ones.
    But there is no errors message :s what can I do to try to fix this?

    I’m still having trouble understanding what’s going on. I see the menu error and can provide a fix for that, but I’m not sure what you mean by “it works only when creating another blog and not for new ones.” Can you explain?

    Hi Michael, I had a similar issue and had originally posted over here
    http://wordpress.org/support/topic/plugin-site-template-use-from-admin

    I further explain what I believe Deamon77 is describing in the last paragraph below…

    Hi Michael,

    Great plugin!! Thank you very much for developing and sharing! This plugin is very close to what I am looking for however I noticed a few things while testing –

    In my original blog I had created custom post types – the post types had transitioned over but any of the posts I had made within those post types had not –

    Also in the settings > Reading > I had set up a static front page as well as designated which page is to be used for the blog posts – for some reason in the new cloned blog from the template these settings were ignored when the new blog was set up.

    When setting up a new site / blog I have noticed that the radio button is visible in all new blog / new site registrations but it only actually works if you are logged in. Also I noticed that if you are logged in as “super admin” it works but if you are logged in as a user that was created and try to activate an additional site under your user name then the custom menu created in the original blog template (appearance > menu) gets created and is listed in the drop down menu and its active but the menu somehow got erased and is basically an empty shell and leaves no menu visible on the new cloned blog.

    Do you see these as possible bugs you would be able to fix?

    Again thank you very much!

    Tom

    Is the problem that you do not see the radio buttons when you are creating a new site at the same time that you are registering as a new user? If so, are you using buddypress? I can recreate the problem with buddypress but not with the regular WP 3.1 interface.

    Mike

    I can see the radio button (at the 2nd step of blog registration just after user registration) but even if I select a template (not the default one) it doesn’t use it when it create the new blog and i get a default blog and not the templated one.

    If I create a blog while being connected, I select a template (not the default one) and i got the foreach error but it seems to work correctly because my new blog is templated.

    I’m using wordpress 3 multi-site without buddypress.

    is this error description better?

    I am not using buddy press just WP3.1

    Radio button is always visible – but the only time it actually works when you select the template is when you are creating a new blog when you are logged in… If you are not logged in you can still select the radio button for the template however the template does not get created when you select it.

    Also – any idea about being able to pull over custom post types into a new blog using this template? As well as the settings > Reading > option so that it will pull in the static front page and which page the posts are on?

    Thanks again!!!
    Tom

    Much thanks for the details. I’ll take a look and see what I can do.

    OK version 1.0 released. Not really a major release because no new features, but I rewrote the guts of the site copy so that it now talks directly to the DB. Should support custom post types. Should also fix menu problems. Also added code to deal with the issue about non-registered users creating new sites. Make sure to read installation instruction in readme file.

    Give it a go and let me know if anything comes up.

    Thanks,

    Mike

    Hi Mike… Thanks so much for updating… I went to try it but it still shows version .4 as the current version.. where can I get version 1.0?

    Sorry, forgot to change the version in php file. Should be good now.

    Mike, That seemed to have worked! So far so good.. I am going to be testing it much more over the weekend – thanks again!

    Tom

    It works perfectly now thanks a lot for your work!

    I just see that privacy option is override by the template when creating a blog while registering
    To test I select Yes let my blog available for google and so on
    but the template option is to “No” so when the template is used, the option goes to no.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: Site Template] doesn't work correctly since .4’ is closed to new replies.