Support » Plugin: Simply Exclude » [Plugin: Simply Exclude] Illegal string offset warnings under php 5.4.5

  • Resolved Maximol

    (@maximol)


    Hello,

    I upgraded my php version from 5.3.8 to 5.4.5 and eversince I am getting the warning “Illegal string offset ‘action’ ” on the settings page an on the blogg itself. The plugin still works, but with these warnings it is not usable.

    This seems to be caused by trying to use a variable as an array that is not an array anymore. For example on line 323
    if ($action_val['action'] == 'i')

    In the previous php version this caused no warnings, but it seems that since version 5.4, they have made some changes to array handling.

    Kind regards,

    Jo

    http://wordpress.org/extend/plugins/simply-exclude/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Sorry ! find the solution but for a wired reason can’t copy the code here only parts are satying after publish! will send the solution to devloper for an update of the php.

    Can you send a link to the code or zip the file with the resolutions as I’m running into the same problem. Thanks, Nic

    Sorry duplicate post for some reason.

    Hello Paul (the developer),
    Can you please comment on any updates coming that will resolve this ?
    Thanks,
    Nic

    I’m also getting that error:

    Illegal string offset ‘action’ in …/public_html/wp-content/plugins/simply-exclude/simplyexclude.php on line 2290

    The plugin is really useful–but would like to not have the error all the time.

    Plugin Author Paul Menard

    (@pmenard)

    Looking into this today. Thanks.

    Plugin Author Paul Menard

    (@pmenard)

    This should not fixed.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Simply Exclude] Illegal string offset warnings under php 5.4.5’ is closed to new replies.