Support » Plugin: simpleSAMLphp Authentication » [Plugin: simpleSAMLphp Authentication] bouncing back to the root blog

  • Having this problem and can’t figure it out! I have upgraded our MU 2.8.6 installation to 3.1 via the manual upgrade. I go to our main site and activate the simpleSAMLphp plugin, go to settings, reset everything, it’s all good.

    Then I go to one of our sub-sites, activate the plugin, go to the settings, reset everything, click save and it bounced back to the simpleSAML settings page of the root blog (not the sub-site). When I go back to the simpleSAML settings of the sub-site, the settings are back to default.

    Any ideas? I’ve even tried older versions of the plugin and no luck.

    http://wordpress.org/extend/plugins/simplesamlphp-authentication/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor fkooman

    (@fkooman)

    Hi,

    Can you confirm this issue is still there with the latest version, 0.5.1 (released today) and latest WordPress (3.1.3) and simpleSAMLphp 1.8?

    If so, can you show me the configuration of simpleSAMLphp, the use of SSL (if at all) and the configuration values of simplesamlphp-authentication?

    Thanks

    Hi,

    i have the same pb with my wordpress 3.1.3 multisite instance using the latest version of the plugin and simplesamlphp v1.8.
    saving the parameters only work for the root blog and not at all for the sub-sites, nothing is actually written in the db.
    using firebug, you can see that form action url in the sub-sites admin configuration page points to the root blog.

    regards, Jean

    Hi,

    the workaround is to insert directly into the db via some sql queries the plug-in settings in each wp_BLOGID_options tables.

    regards,

    This is due to the use of $_SERVER[‘PHP_SELF’] at line 217 in simplesamlphp-authentication.php.

    Using :
    echo '?page=' . basename(__FILE__);
    instead of :
    echo $_SERVER['PHP_SELF'] . '?page=' . basename(__FILE__);
    will resolve the problem, forcing the page to still in the current admin path of the current blog.

    I also suggest to add this at line 208 :
    Replace :
    update_option('simplesaml_authentication_options', $optionarray_update);
    With :

    $current_blog = $wpdb->blogid;
    global $blog_id;
    switch_to_blog($blog_id);
    update_option('simplesaml_authentication_options', $optionarray_update);
    switch_to_blog($current_blog);

    Plugin Contributor fkooman

    (@fkooman)

    But this will break a regular WordPress installation 🙁

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: simpleSAMLphp Authentication] bouncing back to the root blog’ is closed to new replies.