WordPress.org

Forums

SimpleModal Login
Error: error (4 posts)

  1. Richard Vencu
    Member
    Posted 2 years ago #

    After inserting username and password I get this error message: Error: error

    I use WordPress HTTP plugin to force make some of the pages as SSL. Also the wp-login.php and the admin area is under SSL.

    Debugging the form I see it posts to the correct SSL link but the wp-login.php loading is suddenly canceled, there is correct request but there is no response (Chrome, developers tools, network).

    I am making the call from a non-SSL page

    Here is the link: http://www.dentfix.ro The Ctrl-Alt-L is enabled.

    http://wordpress.org/extend/plugins/simplemodal-login/

  2. Richard Vencu
    Member
    Posted 2 years ago #

    Disabling WordPress HTTPS plugin solves the problem but I lose the SSL functionality...

  3. Richard Vencu
    Member
    Posted 2 years ago #

    So I landed here:
    XMLHttpRequest cannot load https://www.dentfix.ro/wp-login.php. Origin http://www.dentfix.ro is not allowed by Access-Control-Allow-Origin.

    Any idea for a workaround?

  4. Richard Vencu
    Member
    Posted 2 years ago #

    I only have one idea so far: to load the simplemodal login form inside an iframe instead from div, iframe source being called with https or not depending on the status of wp-login.php, then do the login from there.

    This way there will be no more crossdomain errors.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • SimpleModal Login
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags