WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: SimpleMap] New Locations not Geo-coding

[Resolved] [Plugin: SimpleMap] New Locations not Geo-coding

  • I’ve got the latest version of WordPress and this plugin – I migrated from 1.2.4 from the previous developer. All existing locations imported fine but new locations are not being geo-coded so new locations just use a default location for the map marker. I can move the marker into the correct location but this is super tedious. There’s no error (on screen on script) and I’ve got a valid API key, etc.

    Sucks because otherwise it’s a great plugin, one of the best out there actually!

    Any ideas what could be going on?

    – Jonah

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hi Jonah,
    Sorry to hear this. Just to confirm:
    1) you got to new location screen
    2) you enter title, street, city, state, zip
    3) you click publish
    4) your screen reloads but the marker isn’t in the correct location

    Is this what your saying? If so, could you give me the address your trying to enter?
    Thanks

    Hi Glenn,

    Affirmative on all items.

    The address is:

    5123 N. Western Ave
    Oklahoma City, OK
    73118

    I tried ‘OK’ and ‘Oklahoma’.

    Thanks,
    Jonah

    i’m having the same problem. this plugin worked flawlessly for me when I first imported my locations. Then today, when I went to add more, it won’t geocode anything. it doesn’t matter how i try to add new locations, either import or manually add them, they still won’t geocode…

    this plugin would be a 5-5 if it worked!

    I’ve run into the same issue. Plugin use to work, but is no longer generating longitude and latitude values.

    @digitalcanopy, I think my issue has to do with being on a shared server or maybe the plugin geocoded too many locations too quickly for google’s standards. either way, I’m getting 620 errors. I used this site to geocode my addresses. It was extra work but I don’t have time to wait for a fix for this problem.

    http://www.gpsvisualizer.com/geocoder/

    Hi guys,
    I actually just found the source for this issue last Friday and am working on a solution. The fix will make it into the premium preview this week some time. I am planning on going back through and pushing multiple bug fixes and some feature updates to the .org version this month.

    The problem is that you’re getting a 620 error from Google – which means too many geocodes requests have taken place from your server. This usually happens when you’re on a shared server. The work around that I’m currently developing is to fallback to their JS API in this event. Their JS API logs the IP of the user rather than the server.

    Glenn

    cool Glenn! can’t wait for the release…

    @glenn, thanks for the update! Do you have an estimated release window for the standard version of the plugin?

    Hi,
    Not anything more specific than that I hope to do it this month. I’ll post back here when it goes live though. It will be a fairly large update including all the bugs listed as fixed in the premium version here: http://simplemap-plugin.com/changelog/ as well as many of the feature updates.

    Additionally, after i release it, I am going to start making sure that any bug fixes applied to the premium users’ preview get applied to the .org version at the same time. It was never my intention to withhold bug fixes for .org but my source code got too far apart on the two versions to make it practical. The upcoming release will sync much of the codebase and the next round of development will include more bug fixes for the .org version.

    @glenn, Hope all is well. I know there was a recent update to the SimpleMap plugin, but I noticed in my version this issue is still occurring. Did the fix not make it into this release? Thanks, -Brian

    Hi,
    I am still getting feedback on the process from our premium support subscribers. It is available to them now and will be available to the .org repo once 2.3.3 is released here. (http://simplemap-plugin.com/changelog/)

    Hi Glenn,

    Not to pile on – loving the plugin as I develop my site – but I’m having this issue as well. I’m on a hostgator account – so maybe someone is doing a ton of geocoding from the same physical server?

    I had also noticed this when I was trying out several mapping plugins, when I deleted the other ones, it worked.

    I’m on a clean install now, up to date, and having this problem.

    Thanks for all you do!

    Dave

    I checked in this AM and it still wasn’t working – I re-pasted in my API key and boom it works! Maybe I put a space in front before? Not sure, but its working now.

    Dave

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] [Plugin: SimpleMap] New Locations not Geo-coding’ is closed to new replies.