WordPress.org

Forums

Simple Twitter Connect
Weird characters in tweets (7 posts)

  1. pyrobon
    Member
    Posted 3 years ago #

    I've never seen this problem posted before.
    But if i use quotation marks (" ") or daphens or many other characters, they appear on my tweet like this:
    &#8220
    The number depends of the character.

    What can i do to resolve this?

    http://wordpress.org/extend/plugins/simple-twitter-connect/

  2. pyrobon
    Member
    Posted 3 years ago #

    Could anyone help with this one? Haven't been able to solve this problem. Please.

  3. Al Berjanskii
    Member
    Posted 3 years ago #

    I have tracked down the problem it appears that wp_parse_args(); is causing this.

    Changing a line in the function: oAuthRequest of twitterOAuth.php included in the STC plugin folder helps alleviate this problem.

    Find:
    $args = wp_parse_args($req->to_postdata());
    Change To:
    $args = $req->to_postdata();

  4. Al Berjanskii
    Member
    Posted 3 years ago #

    I was wrong, the above change does not fix the problem. It looks like it is a bit more complex then what I thought.

    I'm looking into the oAuth URL encoding, perhaps there is still a way to fix this.

  5. Al Berjanskii
    Member
    Posted 3 years ago #

    So in the interest of saving time, I have tried out the plugin 'WP to Twitter' and it appears to handle symbols in URLs just fine.

  6. Samuel Wood (Otto)
    WordPress.org Tech Guy
    Plugin Author

    Posted 3 years ago #

    Did you try the development version of STC first? That always has the latest fixes.

    http://wordpress.org/extend/plugins/simple-twitter-connect/download/

  7. elbivio
    Member
    Posted 2 years ago #

    I still have the problem with development version (0.16)
    is there a way to fix that?
    thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic