Support » Plugin: Simple Twitter Connect » [Plugin: Simple Twitter Connect] Warning and Notices

  • Hi,

    I was testing this plugin in my local apache server and keep getting this warning, only when accessing the STC setting page:
    WARNING: wp-includes/class-http.php:1606 - gzinflate(): data error

    Any clue what might have cause this?

    Also got some notices about undefined acc_token, acc_secret, etc which would be nice if you could clean them up (when you have the time) 🙂

    Thanks for the great plugin!

    http://wordpress.org/extend/plugins/simple-twitter-connect/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Samuel Wood (Otto)

    (@otto42)

    Future versions may fix them, however warnings are not errors and don’t affect the behavior of the plugin. Live sites should have display_errors off anyway.

    No idea what’s causing your data error. That page does attempt to read twitter’s status RSS feed, which will be gzcompressed. If you have anything blocking it, then you’d get a data error.

    Thanks for the reply Otto.

    That’s the problem, I don’t know where to look for what may block it 🙂 The only ‘weird’ thing in my apache setup is that I’m using DYNAMIC_VHOST instead of DEFAULT_VHOST.

    And yes, the plugin works, but there’s another problem I forgot to mention;

    I activated the publish module, and even though the plugin says I’m logged in to twitter with my username printed, it still asks me to authenticate for auto-tweeting (already I gave the permission and twitter redirected me back to the setting page).

    Is this normal with local server?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Simple Twitter Connect] Warning and Notices’ is closed to new replies.