Support » Plugin: Simple Twitter Connect » [Plugin: Simple Twitter Connect] Problem with authenticate

  • enseignement

    (@enseignement)


    Hi,

    I’ve strictly followed the guidelines for creating an application,
    I’ve activated the base plugin + autotweet + button.
    I have entered all the data in the plugin page
    I’ve checked the box “autotweet”
    but once I click on sign in with twitter in the admin, I still arrive to this error page of Twitter :
    http://twitter.com/oauth/authorize?oauth_token=

    Oh là !Cette page n’est plus valide, il semblerait que les informations que vous venez de fournir aient déjà été utilisées. Veuillez retourner sur le site en question et réessayer. Il s’agit sans doute d’une erreur.

    I’m getting desperate. Where should I check to make sure it’s working ?
    I’m using WP 3.0.1 multisite (with no domain mapping) + plugin 0.13.

    Thanks Otto,

Viewing 9 replies - 1 through 9 (of 9 total)
  • metkha

    (@metkha)

    Yeah, I’ve just emailed Otto. I’m having the same problem, and Im running on PHP5. I had it working on another site with WP2.9 and I think it stopped working when I updated to WP 3.0

    My guess is that the plugin is not sending a proper token to twitter and it gets stuck on the oauth authentication page?

    http://twitter.com/oauth/authenticate?oauth_token=

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    No, it gets stuck on the oauth authentication page because either a) you setup the application incorrectly or b) your server is unable to talk to twitter.com.

    Authentication works in this plugin. I just tested it. I’m using it live. So are many other people.

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Also note that the “Help” dropdown in the upper right corner of the settings page will show you the instructions for creating your Twitter application again. Double check them, as it is absolutely *vital* that you follow those instructions to the very letter. Any variation at all will most likely break the thing.

    metkha

    (@metkha)

    Yeah, well, I have followed the instructions correctly (I even double-checked and reset twitter’s keys just in case), the strange thing here is that I had it working on my other site with WP2.9 (which is located at http://www.distritoglobal.com) and now that I have updated to WP3 it stopped working the site that it used to work correctly and in the new site i’m working on.

    I can upload a couple of screenshots of twitter application settings panel if that helps out a little..

    And the theme i’m working on is pretty well coded.. :/ Perhaps my server can’t talk to twitter’s servers? I think dreamhost should give twitter lot’s of headaches regarding spam and all that stuff, perhaps they blocked it? Just wondering..

    metkha

    (@metkha)

    sorry i meant:

    I have updated to WP3 it stopped working on the site that it used to work correctly and (also) in the new site i’m working on.

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Do you have any other plugins that do anything at all related to Twitter?

    If your server can’t talk to Twitter, then you’re screwed and can’t fix it. On the other hand, if you have another Twitter plugin, then it could be interfering because of the OAuth code in the other plugin is doing something differently.

    metkha

    (@metkha)

    I guess I’m screwed. At least Simple Facebook Connect works. Thanks for your time Otto!

    enseignement

    (@enseignement)

    Hi Otto,

    I’m running my own dedicated server : what should I do to allow my server to talk to twitter server ?

    Benjamin

    enseignement

    (@enseignement)

    Otto ?
    Any help would be appreciated.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Simple Twitter Connect] Problem with authenticate’ is closed to new replies.