Simple Twitter Connect
Comment with twitter: PHP Fatal Error. Conflict or bug? (5 posts)

  1. O Ofutur
    Posted 5 years ago #

    This is what happens when somebody tries to authenticate with Twitter.
    PHP Fatal error: Cannot redeclare class twitteroauth in /public_html/wp-content/plugins/simple-twitter-connect/twitterOAuth.php on line 22

    I'm using a WP network, but I don't think that it should be a problem.
    Other plugins that post to Twitter also use OAuth, but I don't think they would name the class exactly the same?

  2. AntaresMHD
    Posted 5 years ago #

    I'm actually having the same problem with WP Multisite, I posted about it a few days ago. Maybe it's related to it.

  3. B
    Posted 5 years ago #

    For what its worth, I'm not using the Simple Twitter Connect plugin, but I am running a WP3.0.1 multisite network, and I'm receiving the same error on a plugin that I wrote. I'm confused as to why this is happening now, it was working fine beforeā€¦ but I'd recommend looking into the WP Multisite matter a little furtherā€¦ I'm seeing the same error message on a different plugin. Good luck.

  4. O Ofutur
    Posted 5 years ago #

    Thanks for sharing :)
    Let us know if you find a fix.
    I'm thinking that everybody had to switch to oauth and everybody is including the class in their plugin and that generates the conflict.

  5. O Ofutur
    Posted 5 years ago #

    The plugin should use:
    if( !class_exists('TwitterOAuth') )

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic