Support » Plugins » [Plugin: Simple Tags (RC1.2)] Getting Fatal Error After Installing RC 1.2

  • Getting the following error after upgrading to the new version. Any idea how I can get the previous version so that I’ll remove this and install that instead.

    Fatal error: Cannot redeclare define_simpletags_path_plugin() (previously declared in /blog/wp-content/plugins/simple-tags/simple-tags.php:38) in /blog/wp-content/plugins/simple-tags/simple-tags.php on line 37

    If anyone knows the solution how to fix this, please let me know…

    Note: My PHP version is < 5

Viewing 15 replies - 1 through 15 (of 23 total)
  • Same error!

    I am having a FATAL error, but it is not the same… It make the Suggest TAG to dont work. And because some reason the Dragging and JS on Dashboard and on Posting Panel does not work when SimpleTag is ON.

    WordPress version 2.9.1
    PHP version 5.2.3

    I can confirm this. Any solution yet? The plugin seems to be partly active in my case…

    The same error? Who can help?

    Yep, I get a fatal error also.

    I, too, got this fatal error message. I reverted back to version 1.6.6 and life is again great.

    WordPress version 2.8.4

    I’m a php hack so not beautiful
    Found class and function name SimpleTagsBase to be the same.
    in base.php.
    Found no instance of new class but two inherit in admin.php and client.php
    Renamed class to include underscores – Simple_Tags_Base in base.php and altered the inherit in admin and client.
    Thus the function can be redeclared – the class can be inherited -started up – no idea yet if it fully functional but looks as if.
    All these are in subfolder inc.
    Best of luck

    Same for me : this plugin could not be installed because it caused a fatal error. WP 2.9.1

    Any change to have this plugin compatible with wp? I dont know but maybe someone should take the pluing and the whole project and carry it on.

    The original developer doesnt seem to be very active on it anymore!

    I twice ended up revering back to Version 1.6.6 with the WP 2.9 compatibility conditional hack. Both 1.7.1 releases failed to do half of what the previous version did.

    I’m stuck with SVN
    Some of you have downloaded a version of development.

    The latest stable version is 1.7.1 RC.12
    A significantly updated version 1.7.2 comes by tomorrow.

    Sorry, but you must download Simple Tags again.
    For PHP4 bugs, I seek a solution for version 1.7.2

    Btw, I tried the new release. Got the same “Plugin failed to reactivate due to a fatal error.” message as I did with 1.7.1 RC 1.1 and RC 1.2.

    And, as in those previous cases, I refreshed my plugins and found that it was supposedly activated anyway. But yet when I edited posts or viewed my Web site, the features it supports were still either missing or broken.

    Once again, for the third time, I reinstalled 1.6.6 with the WP 2.9 compatibility conditional hack. This is getting a bit monotonous.

    Tried today’s and I’m receiving a fatal error. The previous problem was not being able to activate it with the previous release but today’s release…fatal error messages.

    I deactivated it, re-activated it. Problem only works when activating the plug in.

    Similar problem. Updated to and it wouldn’t re-activate – fatal error.
    Tried to install on a fresh WordPress site and same problem occurs.

    After updating this plugin (to, on WordPress 2.9.1), all of my tags and categories disappeared and all my posts showed up as untagged and uncategorized. I had to uninstall the plugin and restore a backup file to get everything to show up again, and had to manually tag and assign categories all over again. Luckily my blog is fairly new so I didn’t have that many posts to fix. Either way, I won’t be using this plugin again. It’s one thing when a plugin fails, it’s another when it screws up a whole web site.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Plugin: Simple Tags (RC1.2)] Getting Fatal Error After Installing RC 1.2’ is closed to new replies.