Support » Plugin: Simple Social - Sharing Widgets & Icons » [Plugin: Simple Social – Sharing Widgets & Icons] Title problems with quotes

Viewing 5 replies - 1 through 5 (of 5 total)
  • It’s more than just quotes. wptexturize should be disabled on the titles if people want to be able to post to most social networks without having strange characters showing up in the titles.

    The solution would be to hook into some function that would restore the normal characters or disable the filters by providing an option in the admin area.

    The solution is to use mb_decode_numericentity

    I have had the same problem. I don’t think I’ll have too much problem editing the widget, but what piece of code should mb_decode_numericentity replace?

    I think I’ve solved the problem. There is a code error in Simple Social. Here’s how you fix it.

    1. Go to your plug-in editor and load the following file:

    simple-social-sharing-widgets-icons/simple-social.php

    2. Then go to line 12 and change the following statement from this:

    $simplesocial_title = urlencode(get_the_title($post->ID) )

    to this:

    $simplesocial_title = urldecode(get_the_title($post->ID) )

    3. Update the file and you’re done

    *Note Thanks to Google I found out that the command urlENcode replaces spaces, quotes, etc., with +’s and %xx’s. The command you need to get rid of that stuff is urlDEcode.

    I changed urlencode by urldecode and now it can’t get the title.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Simple Social – Sharing Widgets & Icons] Title problems with quotes’ is closed to new replies.