WordPress.org

Support

Support » Plugins and Hacks » Simple Page Ordering » [Plugin: Simple Page Ordering] Update that works with 3.4.1

[Plugin: Simple Page Ordering] Update that works with 3.4.1

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi,

    I managed to get it to work on WP 3.4.1.

    I noticed in bugzilla console that it was parseJSON() that got wrong characters and thus throwed an JS error. I had php notices in ajax response. So I did something ugly, but it works :

    in simple-page-ordering.js, on line 62, I put

    var results = [], re = /{([^}]+)}/g, text;
    
    while(text = re.exec(response)) {
        results.push(text[1]);
    }
    var changes = jQuery.parseJSON("{" + results[0] + "}");

    in place of

    var changes = jQuery.parseJSON("{" + response + "}");

    The code simply parses the response to get only what’s inside curly brackets.

    Of course the best solution would be to get rid of the notices and warnings, but maybe the author could put some checks before using parseJSON ?

    Anyway, great plugin, I’ve been looking for something simple with seamless integration in WP. Thanks !

    Plugin Author Jake Goldman

    @jakemgold

    Been super busy, but hoping to make some time within the next week to look at that change and potentially update to 2.0!

    Hi,

    I forgot about this. Actually I realized I was getting php notices in ajax response because WP was in debug mode.

    So for users with standard configuration I guess the plugin should work out of the box 🙂

    Thanks again !

    hope there is a fix soon 🙂 this is the best page/post type order plugin out there. Just doesn’t work with the latest build of WP. (3.4)

    I can reorder stuff but the “order” fields do not update accordingly.

    Sorry, drskullster’s fix does work. i tried and didn’t have success and then realized i had an argument off in my query_posts in my template.

    this will do for now for sure but am super excited about a 2.0 version 🙂

    Is anyone getting this error in 1.4.2? Can you paste the error?

    I can’t seem to make this glitch happen on my install of 1.0.

    Sorry, it’s because I already fixed this issue a year ago in my fork on GitHub.

    https://github.com/cmwelsh/wordpress-simple-page-ordering

    Would someone like to merge in my changes? I added some isset() checks to fix this issue for now. I also added a patch to set the menu_order value when a new Page/Post is created.

    https://github.com/cmwelsh/wordpress-simple-page-ordering/compare/upstream…master

    Let me know if I can help anyone further. I love this plugin. 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Simple Page Ordering] Update that works with 3.4.1’ is closed to new replies.
Skip to toolbar