Support » Plugin: Simple Lightbox » [Plugin: Simple Lightbox] Unchecking Enable in media settings stops jquery.js from loading

  • Resolved perryb

    (@perryb)


    I haven’t tracked this down to an interaction with another plugin yet but if I uncheck Enable on Pages or Enable on Home Page etc in Media Settings this stops WordPress from loading jquery.js.

    I noticed the problem when one of my custom scripts stopped working on an archive page that I don’t want light-box to load on. Rechecking solved the issue.

    So, barring some other filtering the light-box script will have be loaded on pages where I don’t need it.

    Is it just me?

    http://wordpress.org/extend/plugins/simple-lightbox/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Archetyped

    (@archetyped)

    Hi,

    SLB does not unregister scripts that are registered by other code in WP. Does your custom script, theme, etc. explicitly load jQuery?

    Note that WP does not load jQuery on the frontend by default, so if there is no code to explicitly load jQuery on a specific page/post type, then jQuery will not be loaded. For example, SLB does not request jQuery to be loaded on pages when the “Enable on Pages” option is not enabled.

    Plugin Author Archetyped

    (@archetyped)

    Marked as resolved due to inactivity.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Plugin: Simple Lightbox] Unchecking Enable in media settings stops jquery.js from loading’ is closed to new replies.