WordPress.org

Support

Support » Plugins and Hacks » Simple Fields » [Plugin: Simple Fields] jQuery UI version conflict

[Plugin: Simple Fields] jQuery UI version conflict

  • It seems there are conflicts with some jQuery UI components used in Simple Fields. The lines

    wp_enqueue_script("jquery-ui-effects-core", "http://jquery-ui.googlecode.com/svn/tags/1.8.1/ui/jquery.effects.core.js");
    wp_enqueue_script("jquery-ui-effects-highlight", "http://jquery-ui.googlecode.com/svn/tags/1.8.1/ui/jquery.effects.highlight.js");

    refer to the 1.8.1 version of jQuery UI, while the WordPress admin still uses 1.7.3. This can cause parts of the admin interface using UI widgets to fail (found out with Events Manager Extended). I switched those for their 1.7.3 counterparts and everything seems to work fine:

    wp_enqueue_script("jquery-ui-effects-core", "http://jquery-ui.googlecode.com/svn/tags/1.7.3/ui/effects.core.js");
    wp_enqueue_script("jquery-ui-effects-highlight", "http://jquery-ui.googlecode.com/svn/tags/1.7.3/ui/effects.highlight.js");

    I don’t know how versioning works for wp_enqueue_script but I guess it could be used to get around that too.

    http://wordpress.org/extend/plugins/simple-fields/

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Simple Fields] jQuery UI version conflict’ is closed to new replies.
Skip to toolbar