WordPress.org

Support

Support » Plugins and Hacks » Simple Fields » [Plugin: Simple Fields] Can't select images from library

[Plugin: Simple Fields] Can't select images from library

  • After updating to WP 3.3, I’m finding that it’s no longer possible to select a file from the Media Library for images that are stored by Simple Fields. It’s still possible to upload images, so the workaround for now is to have the users upload their files twice if they appear on two pages.

    Images that aren’t stored by Simple Fields, like the featured image, aren’t affected.

    I’ve uploaded an example image to show an example of what the Media Library controls look like.

    http://wordpress.org/extend/plugins/simple-fields/

Viewing 10 replies - 1 through 10 (of 10 total)
  • I found what looks like a fix in the forums here:

    add_filter( 'get_media_item_args', 'force_send' );
    function force_send($args) {
    	$args['send'] = true;
    	return $args;
    }

    I just added that code to the top of the functions_post.php file in the plugin and the “Select” button (which is apparently really the “Insert into Post” button, just renamed later in the plugin) shows up once again for me.

    Yes the fix works for me. Thank you cm258

    Works for me as well; saved my ass today. Kudos, cm258!

    Thanks for this. At first it seemed like it solved the issue, as the ”Select” button was back.

    But now, when I try to select a picture it first opens the media lightbox as a new page (at not as a lightbox at all). When I navigate to a picture and click ”Select” I get a blank white page…

    Anybody else having this issue?

    Thanks for posting the fix – it was driving me mad!

    Thank you very much mate

    There is another bug – the popup Media Library doesn’t even show. It goes to another page.

    I am sure this bug came with WordPress 3.3, I even can not collapse the right menu when on the page containing simple fields. Please, fix the bug 🙂
    Good luck!

    And something with text area exactly. When there is no text-area, popup appears and collapse menu works also.

    I tried the above fix, and the select button shows, but after I click select, I wind up on a blank white page — and the item is not associated with that field. Has anyone found a workaround?

    thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Simple Fields] Can't select images from library’ is closed to new replies.
Skip to toolbar