Support » Plugins and Hacks » [Plugin: Simple Facebook Connect] Unable to post to Fan Page

  • Hi,

    I have used SFC in the past with little issues other than getting the facebook app settings correct however I am experiencing an issue I have been unable to correct.

    I hit “grant SFC permission” the facebook window pops up and says I am granting it permissions to post to all my pages, profile, etc… I get the following after this:

    User ID and Access Token found! Automatic profile publishing is ready to go!

    Application Access Token not found. Cannot autopublish to Facebook Application. Try re-saving this page.

    Fan Page Access Token not found. Cannot autopublish to Facebook Page. Try re-saving this page.

    So I have tried uninstalling the App and re installing, same outcome after granting access again. For the record My Fan page has a username (facebook.com/myfanpage) I did manage to find the ID by clicking on edit page and coping the ID from the url there. I am very confused on the issue here so any help would be appreciated!

    I have also tried uninstalling SFC and re installing with no luck.

    I am wondering if it is a settings issue on the application side because Facebook seems to have totally changed the way they are setup up in the settings page. Luckily I already had a app setup previously and i mirrored its settings to this new pages app.

Viewing 15 replies - 1 through 15 (of 24 total)
  • Update:

    I can manually hit the “publish to Fan Page” button on any page/post edit screen and it will post to my fan page.

    This is very confusing so any help is much appreciated!

    Bump

    Still have been unable to fix this issue

    Could it be caused by the fact that this was not originally my fan page but is instead my Wife’s fan page which she has granted me admin privleges?

    If you’re getting “Application Access Token not found”, then you have a more fundamental problem, since that doesn’t rely on the page settings in any way at all.

    If your server doesn’t have the capability to talk to facebook’s servers via SSL, then it won’t be able to get the access tokens. This usually is because your PHP was compiled without OpenSSL support.

    There’s no good fix for this other than to use your hosting system to recompile PHP with SSL support. If they provide that option. Facebook requires SSL communication, for security.

    So then why would one say it found a token but the application and fan page token not be found?

    Could it be the app settings?

    Also the app does allow me to manually hit publish to facebook fan page while editing and in the window that pops up it does it via my app that i set up….

    Really confused what the issue is.

    The personal token is not the same as the application and page token. Personal tokens come from your browser and the cookie interaction. App and Page tokens have to be gotten directly from FB in other ways.

    And the manual publishing is from your browser to Facebook directly, not going through the plugin or your web server at all. This is done with Javascript and Facebook’s own code.

    I have searched and searched but cannot find a fix for this .. .I am using Wp 3.3.1 and the latest version of SFC

    i have removed app and regranted permission but still get the error

    Fan Page Access Token not found. Cannot autopublish to Facebook Page. Try re-saving this page.

    See screen shot here http://imm.io/f56I

    Is there a way to fix this issue?

    Figured out .. had wrong id for the fanpage in the settings of sfc….. 🙂

    im still getting this error

    I am able to setup automatic fan page posting, and it works for a while. But somehow, after a day or so it stops posting automatically and I get the following error on the SFC Settings page:

    “Fan Page Access Token not found. Cannot autopublish to Facebook Page. Try re-saving this page.”

    If I click the Grant SFC Permissions button then re-save settings, things start working again. Really hate having to reestablish the permissions in order for auto posting to work. Any thoughts?

    Bump

    I have the same issue, “Fan Page Access Token” seems to get lost every few days.

    Not sure how it could lose the token.. That’s stored in the database with the options. If it’s “not found” then the options got re-saved without it or something similar. Tokens as stored by the plugin don’t expire.

    Yes, I know it’s very strange, but it just happened again. I’ve checked the preferences page, and 3 lines were green, I pressed “save” and the last one’s (page access token) changed to “white” with the error “Fan Page Access Token not found. Cannot autopublish to Facebook Page. Try re-saving this page.”.

    I tried to save again without luck, and I had to click again the grant permissions button. After reloading the page (also, after a manual save later), three lines keep being green.

    I don’t know if there’s any way to “log” db queries to find the problem

    It keeps happening a lot of times. Does the plugin “reloads” the tokens stored in the database in any way? If the user logs out from FB, or if it logins to WordPress without being logged into FB?

    I granted permissions, but usually, the user who posts is another one. Do you know if this has any problem?

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Plugin: Simple Facebook Connect] Unable to post to Fan Page’ is closed to new replies.