WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Simple Facebook Connect] Since update, og:image is not working.

[Plugin: Simple Facebook Connect] Since update, og:image is not working.

  • How do,

    Since the latest update on SFC, the og:image is not picking up the image that it should.

    I’ve ran through the URL to the post in FB linter and everything else is fine other than the og:image.

    I check every now and then just to make sure everything works ok because I do have other FB codes within the my blog,, but never before have they ever conflicted so I have to put it down to the recent update.

    A bit stuck on this one.

    http://wordpress.org/extend/plugins/simple-facebook-connect/

Viewing 15 replies - 1 through 15 (of 16 total)
  • I’ve been getting this:

    Like Button Warnings That Should Be Fixed

    Inferred Property og:image missing. og:image meta tag is necessary for Facebook to render a News Feed story that generates a high clickthrough rate.

    Open Graph Warnings That Should Be Fixed

    Inferred Property The og:image property should be explicitly provided, even if a value can be inferred from other tags.

    Plugin Author Samuel Wood (Otto)
    Keymaster

    @otto42

    Ugh. Yes, there’s a bug there. I’ll fix it.

    You’re a frickin’ lovely fella, Otto. Thanks, man 😉

    Plugin Author Samuel Wood (Otto)
    Keymaster

    @otto42

    Fixed. Update the sfc-media.php file to get the fix.

    http://plugins.svn.wordpress.org/simple-facebook-connect/trunk/sfc-media.php

    On it..

    Mmmm. Line 23 there’s an issue

    If you look at my site: http://thetruejoe90.com – there appears to be a line which has come into view at the very top of the site.

    function.array-merge ?!

    Errors that must be fixed

    Body Meta You have <meta> tags ouside of your <head>. This is either because your <head> was malformed and they fell lower in the parse tree, or you accidentally put your Open Graph tags in the wrong place. Either way you need to fix it before the tags are usable.
    Like Button Warnings That Should Be Fixed

    Inferred Property fb:admins and fb:app_id missing. fb:admins or fb:app_id is necessary for Facebook to render a News Feed story that generates a high clickthrough rate.
    Inferred Property og:title missing. og:title meta tag is necessary for Facebook to render a News Feed story that generates a high clickthrough rate.
    Inferred Property og:type missing. og:type meta tag is necessary for Facebook to render a News Feed story that generates a high clickthrough rate.
    Inferred Property og:image missing. og:image meta tag is necessary for Facebook to render a News Feed story that generates a high clickthrough rate.
    Open Graph Warnings That Should Be Fixed

    Inferred Property The og:url property should be explicitly provided, even if a value can be inferred from other tags.
    Inferred Property The og:title property should be explicitly provided, even if a value can be inferred from other tags.
    Inferred Property The og:description property should be explicitly provided, even if a value can be inferred from other tags.
    Inferred Property The og:image property should be explicitly provided, even if a value can be inferred from other tags.

    CynCreative
    Member

    @cyncreative

    I’m getting the line 23 error, too… has this been fixed yet? Thanks!

    downloaded the fix for sfc-media > getting the line 23 error

    Plugin Author Samuel Wood (Otto)
    Keymaster

    @otto42

    Fixed again, but damn, turn off display_errors. No site should ever have that enabled. Crazy!

    how would I do that?

    Plugin Author Samuel Wood (Otto)
    Keymaster

    @otto42

    CynCreative
    Member

    @cyncreative

    Sorry but where is the fix for the error? I’m still getting it. Thanks!

    Thanks for taking the time out, Otto.

    @CybCreative. Scroll up.

    CynCreative
    Member

    @cyncreative

    @ttj90, are you talking about the fix at:
    http://plugins.svn.wordpress.org/simple-facebook-connect/trunk/sfc-media.php ?

    If so, this doesn’t work for me. I’m still getting the Line 23 error.

    thanks

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Plugin: Simple Facebook Connect] Since update, og:image is not working.’ is closed to new replies.