WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Simple Facebook Connect] SFC Comments box hides captcha

[Resolved] [Plugin: Simple Facebook Connect] SFC Comments box hides captcha

  • I’ve found a conflict between Simple Facebook Connect “SFC Comments” module and SI CAPTCHA Anti-Spam plugin. As soon you aren’t logged in to facebook, everything is fine (Image 1), but when you log in the facebook box “hides” the captcha cose along with the three text fields (Image 2), making it impossible to post.
    I’ve checked with Firebug and i found that sfc comments hides the “comment-user-details” div, and the captcha is inside. How can I control what is hidden by this module? What file can I edit to fix thisP

    http://wordpress.org/extend/plugins/simple-facebook-connect/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Well, you have two real options:

    1. Stop using the captcha plugin. Captcha’s don’t work anyway. This is well-proven.

    2. Modify the captcha plugin to put its image somewhere else outside that div.

    You can’t control what is hidden by the SFC-Comments plugin. So put the captcha outside the div.

    1. Stop using the captcha plugin. Captcha’s don’t work anyway. This is well-proven.

    I can’t. I want everybody to be able to comment without registering, so I need a good way to keep automated spam away. Captcha+Akismet should do the job. Do you know other good alternatives?

    2. Modify the captcha plugin to put its image somewhere else outside that div.

    Do you know how? I’m not so good with php.

    Thanks for your answer, anyway.

    Do you want to try a workaround?

    I am not sure if it will fix it or how it will look, but can try it and let me know?

    edit si-captcha.php (about 45 lines up from the bottom)

    change:

    add_action( 'comment_form_after_fields', array(&$si_image_captcha, 'si_captcha_comment_form_wp3'), 1);
    add_action( 'comment_form_logged_in_after', array(&$si_image_captcha, 'si_captcha_comment_form_wp3'), 1);

    to:

    add_action( 'comment_form_top', array(&$si_image_captcha, 'si_captcha_comment_form_wp3'), 1);
    add_action( 'comment_form_top', array(&$si_image_captcha, 'si_captcha_comment_form_wp3'), 1);

    Make sure to test when logged in and when logged out of WordPress
    Did it work?

    Mike

    Yes, it works, but the captcha is now on top of everything, just below the “Leave a reply” text. Any chance to put it down, like between the facebook box and the comment field or just before the “Post Comment” button? (Image)

    Thanks

    Comment out those two lines of code and try it:
    put a double slash in front of each line of code

    //add_action( 'comment_form_after_fields', array(&$si_image_captcha, 'si_captcha_comment_form_wp3'), 1);
    //add_action( 'comment_form_logged_in_after', array(&$si_image_captcha, 'si_captcha_comment_form_wp3'), 1);

    Does that work?

    No, it doesn’t. Now the captcha is under the post button (Image), and that’s pretty ugly to see.

    I thought it would have been an easy job, I’m sorry.

    You are almost there!

    Check this setting:
    “Change the display order of the catpcha input field on the comment form.”
    This will move the button to the bottom again.

    It works now, thank you so much.

    Plugin Author Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    I can’t. I want everybody to be able to comment without registering, so I need a good way to keep automated spam away. Captcha+Akismet should do the job. Do you know other good alternatives?

    Cookies for Comments. Works way better than any captcha.

    Cookies for Comments. Works way better than any captcha.

    I really don’t see how can a cookie save me from spam. The plugin description isn’t so clear to me. I would be very grateful if you could explain better.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] [Plugin: Simple Facebook Connect] SFC Comments box hides captcha’ is closed to new replies.