WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Simple Facebook Connect] Problem with Major Update

[Resolved] [Plugin: Simple Facebook Connect] Problem with Major Update

  • yendi
    Member

    @yendi

    Hi Otto… I’ve been using (and loving) you plugin for about 2 months now, but with the recent update I no longer can see anything… I have edited my theme to manually display the like button like this:

    sfc_like_button(array(‘action’=>’like’, ‘layout’=>’button_count’));

    It was working perfectly until this major update. Now it doesn’t display neither this, nor any widget ( I had the fan box and activivy widgets ). And I have already turned on all the sub-plugins.

    Please see my site: http://papaspro.com, if you see the source code the fb code is there, but it is not displaying… what can it be… can you help me figure this out?

    http://wordpress.org/extend/plugins/simple-facebook-connect/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Samuel Wood (Otto)
    Keymaster

    @otto42

    It looks fine to me. I can see all those widgets on your page, along with the like button.

    yendi
    Member

    @yendi

    The upper like button I added myself… 🙁 Sorry for not clarifying that

    Your button should appear before the Twitter button, right below the title of each post… See (http://papaspro.com/p.php/temas/lectura/avances-en-chino-16-meses/) for example

    I’ve already checked in three different computers with 3 different browsers each, and I see nothing… the weirdest thing is the widgets display on the home page (as you saw) but NOT on single posts. See http://papaspro.com/p.php/temas/lectura/avances-en-chino-16-meses/ again as an example.

    Thank you!

    Plugin Author Samuel Wood (Otto)
    Keymaster

    @otto42

    Your Facebook Share button is using the old Connect libraries, and it’s loading the http://static.ak.fbcdn.net/connect.php/js/FB.Share javascript code. This is incompatible with the new Facebook Javascript SDK, and causing it to not load.

    There is no fix, the old Connect libraries, and by extension the Share button, is just totally incompatible. Only way to make it work is to remove it.

    Facebook no longer supports the Share button at all and probably won’t be migrating it to their new code. I’m surprised it’s still even working at this point.

    yendi
    Member

    @yendi

    Thank you for sharing your knowledge. I disabled that share button and now everything works again. 🙂

    Beer’s on me! Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] [Plugin: Simple Facebook Connect] Problem with Major Update’ is closed to new replies.