WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Simple Facebook Connect] Not posting to Facebook

[Plugin: Simple Facebook Connect] Not posting to Facebook

  • Jerome
    Member

    @market4android

    I am using both SFC and STC for the record.

    I posted in another thread but got no reply, so I’ll make my own.

    I have all three of my tokens, the text is with a green background. I had one post work. Then I uninstalled because I disliked the shortlinks the plugin used. Then, I reinstalled, and saved my setting (that were already there… bad plugin deletion cleanup, dev) and tried to post again and it didn’t work. I the found out that I lost my tokens, two of the, the top and bottom of the 3 in the list. So, I had to sign back into the FB account and re-auth, which was successful. Still cannot post automatically to facebook (or manually)…..

    Help!

    http://wordpress.org/extend/plugins/simple-facebook-connect/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Samuel Wood (Otto)
    Keymaster

    @otto42

    The plugin settings cleanup happens on delete. That’s why there is an uninstall.php file.

    Edit: Hah. Uninstaller had a minor bug. Fixed.

    If you don’t have the green lines, then try saving that page again. This causes it to go renew those tokens with Facebook.

    Jerome
    Member

    @market4android

    LOL yeah… I still had my settings when I reinstalled the plugin.

    Anyways, I still have all tokens, they’re all good, but still no posting to Facebook, and I guess you can say I’ve tested it about 80x since yesterday because I’ve made 80 new posts.

    Plugin Author Samuel Wood (Otto)
    Keymaster

    @otto42

    I dunno then. If you have the tokens, and the auto-posting is enabled, then it will post. Works for me.

    Jerome
    Member

    @market4android

    So from what I am gathering, I need to go find a new plugin?

    Plugin Author Samuel Wood (Otto)
    Keymaster

    @otto42

    If SFC doesn’t work, I doubt another plugin will.

    You need to figure out why it’s not posting. What is it about your site and setup that is breaking things? Until I know the problem, I can’t know the solution.

    Jerome
    Member

    @market4android

    I explained exactly what happened. I’ve sat here and spent so many hours trying to get it to work already and it’s obviously a bug and I (also obviously) can’t figure out what ti is, but it happened after I uninstalled the plugin. I guess I can try to search my database real quick and see if something isn’t right in there…

    Jerome
    Member

    @market4android

    database has all the right info (keys, etc) so I have no clue what else could be causing the issues… I’ve checked php error logs, nothing there. I have all 3 tokens. i personally think it definitely has to do with me uninstalling, then reinstalling, the plugin.

    Jerome
    Member

    @market4android

    And finally, I will try another FB plugin real quick, to see if I cannot further confirm my theory.

    Plugin Author Samuel Wood (Otto)
    Keymaster

    @otto42

    Uninstalling and reinstalling doesn’t change the code or the way that code works. That wouldn’t have any effect.

    If no errors occur when you make a new post, then I have no explanation. Any errors should happen and be output back to the screen. If no errors happen, then it’s either not trying to post at all (option disabled) or it’s successful.

    Jerome
    Member

    @market4android

    Well, I tried Wordbooker, and it says the post was successful. So now I am completely frickin stumped!

    (wordbooker has detailed logs for each post)

    Jerome
    Member

    @market4android

    I got wordbooker to work.. http://www.facebook.com/AndroidTabApps

    doesn’t make sense to me. Will do some more trying later with SFC. I like SFC a million times better because no branding (like WB has) plus seems cleaner. Don’t get me wrong, but I still think I may have a bug for you, later.

    Jerome
    Member

    @market4android

    Well I still cannot get the SFC to post to Fan Page, so I guess I am going with Wordbooker. Thanks 😐

    Plugin Author Samuel Wood (Otto)
    Keymaster

    @otto42

    There’s nothing wrong with SFC in this respect. Working for me, working for matt, working for wordpress.org itself. Everything seems to be working on my end. Gotta be something specific to you.

    We use SFC a *lot*. If this part was broken, trust me, I’d know. So it’s got to be something on your site.

    Jerome
    Member

    @market4android

    I personally would attribute the problem to something with FB before my site because I find it strange how, when with proper config, wordbooker works like a charm. But, Alright, I will disable every one of my plugins and leave ONLY sfc running. I’ll be back with the results.

    Jerome
    Member

    @market4android

    Are there any known conflicts with any of these plugins?

    Active Plugins :
    Akismet ( 2.5.3 )
    Contact Form 7 ( 3.0 )
    Counterize ( 3.0.33 )
    FeedBurner FeedSmith ( 2.3.1 )
    Multiple Galleries ( 0.4.1 )
    NoFollow Link ( 1.0 )
    Redirection ( 2.2.9 )
    Savrix Android Market ( 2.1.2 )
    STC – Comments ( 0.15 )
    STC – Login ( 0.15 )
    STC – Publish ( 0.15 )
    STC – Tweet Button ( 0.15 )
    Simple Twitter Connect – Base ( 0.15 )
    WordPress.com Stats ( 1.8.5 )
    WordPress SEO ( 1.0.3 )
    wp-jquery-lightbox ( 1.3.3 )
    WP-PageNavi ( 2.74 )

    And is this a problem for your specific plugin?

    Curl Status: Curl is available but cannot access Facebook – This is a problem – Please check your Server error logs.
    Fopen Status: Fopen is available and can access Facebook – All is OK

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: Simple Facebook Connect] Not posting to Facebook’ is closed to new replies.