Support » Plugin: Simple Facebook Connect » [Plugin: Simple Facebook Connect] JetPack conflict and auto post doesn't work

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    ShareDaddy is broken. I’ve reported this upstream, but they have yet to fix it.

    In the /jetpack/modules/sharedaddy/sharing-service.php file, on line 400, you’ll find these three lines of code:

    // Only show once
    if ( isset( $shared_with_posts[$post->ID] ) )
    	$show = false;

    Remove those lines and ShareDaddy will work properly.

    Feel free to point out this to them. Also tell them to read this article, because ShareDaddy is yet another plugin that is doing-it-wrong:
    http://ottopress.com/2011/actions-and-filters-are-not-the-same-thing/

    Filters should not have unexpected side effects, and that includes only working one time.

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    As for your problem with the publisher, do you have the green rows for the Fan page on the SFC settings screen? If so, then it’ll publish properly. It not, then you need to grant permissions and Save the settings.

    Ok I will test your modification suggestion of sharpen-service.php file.

    For publisher problem I have already test and it’s doesn’t work. I think that application is OK with Facebook because manually publish working.

    http://cl.ly/3h3L1Y430a2s1T0s1C1n

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Okay, see, you’re not getting those green lines. There should be three of them there.

    This indicates to me that your hosting system’s PHP install doesn’t have the OpenSSL libraries. Without those, then PHP can’t talk over HTTPS to Facebook’s Graph API, which means that SFC just isn’t going to work for like 80% of what it does.

    There’s no easy fix for this. Get your webhost to activate the OpenSSL libraries on the PHP installation.

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Okay then, I don’t know what the problem could be. Did you click the button to grant the permissions? Did you save the page? When you do both of these things, SFC tries to contact Facebook’s servers to obtain the access tokens. When it has the access tokens, you’ll see three green lines there. Until those lines are green, auto-publish can’t possibly work.

    Manual publish will work all day long, because that’s not going through the Graph API, that’s just a browser popup. That’s going from your browser to Facebook directly, it’s not using the backend code to publish.

    The plugin worked great in the previous version.

    When I click the button Grant Permission I have the Facebook authorization window and when I accept the window closed without refreshing the admin page of your plugin and I clicked the save button several times, but only the first test line is green.

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    The previous version only did the meta tags in the header if you used the share or like button features. The new version does meta tags all the time, and uses the Graph API and new Javascript SDK.

    Basically, Facebook has deprecated the old Connect code, and it will stop working after October 1st. So what the “old version” did is irrelevant, since it won’t work anyway.

    The Grant Permission button will pop up that window, allowing you to grant the permissions. It doesn’t cause a refresh, it just does the authorization. When you click Save, the backend code talks to the Facebook Graph API to get the access tokens. When it has them, then those lines turn green. If it can’t get them, or you haven’t authorized it, then they won’t turn green. They’re dummy lights, basically.

    Until you can figure out why your server can’t talk to the Facebook Graph API, publish just won’t work.

    It’s possible to clean with:
    – Uninstall plugin (I know how to)
    – Clean database options (I don’t know how to)
    – Remove Facebook auth (I don’t know how to)
    And do a fresh install?

    Do you have a test page to test the connection or do you want me to do a test from the server? (I am the system administrator)

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Fresh installs won’t fix the problem. They never do. The problem is in the server setup and the plugin being unable to contact Facebook. Maybe it’s firewalled. Maybe it can’t talk over SSL/HTTPS. I have no way to tell you exactly why it’s not working, but I can tell you that ‘reinstalling’ won’t fix it.

    I am having the same issue. I cannot get the application or fan page access tokens for sites on one of my servers.

    I have php 5.3.6 running and OpenSSL is configured. I have tried everything I can think of, figuring it must be my server configuration (since this works on other servers I use).

    Your last comment has me thinking. Maybe its the firewall. I only have ports 80 and 443 open. Do you know what other ports are needed?

    Thanks for all your time on this.

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    No ports. 80 for HTTP, 443 for HTTPS, that’s it. Maybe your host is blocking based on hostname?

    I don’t have any rules for outgoing traffic on my firewall.

    What’s the URL that I can test from my server to check that there is no problem?

    Hi,

    Problem for the auto publish is resolved with version 1.1 of plugin Simple Facebook Connect. Thanks 🙂

    Regards,

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Yes, turned out to be a problem with hosts that didn’t have the latest certificate authority lists. 1.1 should fix it.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Plugin: Simple Facebook Connect] JetPack conflict and auto post doesn't work’ is closed to new replies.