Support » Fixing WordPress » [Plugin: Simple Facebook Connect] Extra http:// and trailing /

  • I have installed this on 4 blogs. It works fine on the first one but the other 3 have an extra http:// and / for the facebook share button. Do you know what might be causing that?

    Thanks
    Tanya

Viewing 8 replies - 1 through 8 (of 8 total)
  • Nope. I’d have to see the site itself. Got a link?

    http://www.geekgoodgirl.com/ is where it is working fine. Here are 2 of the other sites where it is doing the extra:
    http://www.gotbaddog.com/ and http://www.gotbuddy.com/

    … Yeah, okay, that’s just weird. It doesn’t make any sense, because that broken URL isn’t on the page anywhere. The code being produced by the plugin is correct. Looks like Faceboook is messing up, but I haven’t the faintest idea how to fix it.

    Thanks, that is what it looked like to me too. I will try deleting the app from them and start over. Strange that it worked for the first site and not the other 3. Also that the connect and like links work just not the share.

    sing2zing

    (@sing2zing)


    This is happening to me as well. The link is posted on facebook but with the extra http:// the link does not work. I’ve tried changing the location in the app removing the http://, saving changes, but it comes back automatically.

    http://www.stoopphilly.com

    Moderator Samuel Wood (Otto)

    (@otto42)


    It’s happening to everybody, and it’s not a problem with the plugin. I’ve seen it happen on many sites running the share button but not running my plugin as well.

    In other words, it’s a generic Facebook problem and there’s nothing I can do about it.

    sing2zing

    (@sing2zing)


    I used the Share on Facebook plugin and it works fine. geekgoodgirl, your http://www.geekgoodgirl.com site is inserting the extra http:// as well.

    Moderator Samuel Wood (Otto)

    (@otto42)


    Workaround for this, for now. If you use the non-XFBML way of creating the button, it seems to work better. Facebook isn’t supporting XFBML very well anymore, so they just aren’t fixing their broken code much.

    Anyway, add this to your wp-config file:
    define('SFC_SHARE_USE_XFBML',false);

    This makes SFC-Share use an alternate approach, which seems to work better and not have this problem.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Simple Facebook Connect] Extra http:// and trailing /’ is closed to new replies.