WordPress.org

Support

Support » Plugins and Hacks » Simple Facebook Connect » [Resolved] [Plugin: Simple Facebook Connect] Doesn't publish posts automatically to Facebook

[Resolved] [Plugin: Simple Facebook Connect] Doesn't publish posts automatically to Facebook

Viewing 4 replies - 1 through 4 (of 4 total)
  • An update: publishing to fan page doesn’t working neither manually (I double-checked the page number ID), while to profile works well.

    Plugin Author Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    If it doesn’t work manually, then you either don’t have permission to publish to that page, or the Page ID number is incorrect.

    The “Manual” publisher uses a different method, where you’re actually posting to your page directly, from your browser to Facebook. Essentially, it cannot fail because of the plugin, because the plugin isn’t doing the publishing at that point, you are. Just in a little pop-up window.

    So I’d re-examine your assumptions here. Are you allowed to publish things to that page? Are you trying to publish as “you” instead of as “the page”? SFC is making the inherent assumption that you want to publish to the Page as the Page, so if you’ve edited the page settings to turn that off, then it will also fail for that reason.

    Since it is my page and I use it EVERY DAY, the answer is yes – I’m allowed to publish on it. As I said, I double-checked everything – the ID is correct (we are speaking only about the numeric ID, right, not about the whole URL?) and the three permission fields that grant free access are green. I’m not expert in FB settings, yet all applications I set up work well on other sites/blog. There is possible your plugin needs other settings made in FB application, but however I think you should provide all the necessary information in order that people can use it with ease. By the way, this is the second problem and I’m more interested in the automatic publishing feature of the plugin, which doesn’t work. Could you provide me some helpful information regarding this? I saw yesterday somebody else had a similar problem, so there is possible the recent WP update caused some bugs? Thanks in advance!

    Plugin Author Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    I don’t know what more to tell you. I can’t solve your problems without more detailed information as to the cause of the problems. The publishing works fine for me and many others, so I’d need to know what’s different about your particular case to figure out the problem.

    Perhaps you should use a different plugin. The official Facebook plugin does publishing too.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] [Plugin: Simple Facebook Connect] Doesn't publish posts automatically to Facebook’ is closed to new replies.
Skip to toolbar