WordPress.org

Forums

[resolved] [Plugin: Simple Facebook Connect] connect/share button issue (9 posts)

  1. eighteesix
    Member
    Posted 5 years ago #

    Hello--

    First of all, I have all necessary modules activated. When I click the connect button, it asks me to login to FB, but then redirects me back to my blog's index (in the popup window).

    Also, I have enabled the share button. however, regardless of how I choose to insert it (before, after, both, or manually), I cannot get it to appear. I've looked around for answers and can't seem to find any.

    Thanks in advance!

    http://thisiswhywefail.com

  2. You don't have the connect button anywhere but on the sidebar. That one doesn't really do anything. Have you tried the one for the comments form?

    I can't explain the share button. It's there in the code, but it's not rendering. Perhaps the other share plugin is interfering in some manner.

    Edit: The connect button on the login page gave me the answer. You have the wrong connect URL configured for your application. Your site is http://thisiswhywefail.com but you configured the application as http://www.thisiswhywefail.com . That invalid www makes a difference. Go edit your application and remove that bit: http://www.facebook.com/developers/

  3. eighteesix
    Member
    Posted 5 years ago #

    i changed it. working now. although it says i need to specify an email domain to ask for someones email address.

    also, after i changed the app settings, when i pressed the connect with facebook button on the sidebar, all the "share" buttons appeared, and are sticking now, even after i log out of facebook. very strange.

    edit: is there any way to make the connect button disappear or change in any way once they are connected? and finally, in Firefox and Chrome browsers, the "share" pop up is divided into two blocks, one is the facebook part, and the other bottom half is empty white space thats covering the facebook content so you can hit any buttons. any ideas?

  4. eighteesix
    Member
    Posted 5 years ago #

    sorry-- the error is: You must configure an email domain before requesting a user's email address.

  5. Same deal, go back to the Facebook App and configure an email domain. It's on the Advanced tab.

    An email domain would be the domain that your email comes from. My email is otto@ottodestruct.com, so my email domain is ottodestruct.com.

    As for the button hiding, no, not yet. Like I said, that Connect sidebar button is fairly pointless. I wouldn't use it yet for anything, it's just a basic demo.

    As for the popup, I have no control over its content. Facebook generates that popup.

  6. eighteesix
    Member
    Posted 5 years ago #

    alright. one issue fixed. your suggestion was to use the connect button on the comments page instead, however, i do not see one on mine. thoughts?

  7. eighteesix
    Member
    Posted 5 years ago #

    also--just noticed, after granting all three permissions, the plugin still wont automatically publish to my fan page wall. it will publish manually in the edit post page, but not automatically. ideas?

  8. The comments plugin requires minor theme modifications. Read the readme.txt file that comes with the plugin.

    Auto-publishing to Pages is flaky. It works sometimes, but Facebook has been having issues with their API. No way I can fix it at the moment.

    Note: On the settings page, there should be a message that says "User ID and Session Key found! Automatic publishing is ready to go!" If you don't see that, and have granted those three permissions, then hit the Save Settings button and see if it appears. Basically, you have to Save at least once after granting permissions for it to be able to grab the session key.

  9. eighteesix
    Member
    Posted 5 years ago #

    great, thank you very much for your help otto. youve been most helpful.

Topic Closed

This topic has been closed to new replies.

About this Topic