Support » Plugin: Simple Facebook Connect » [Plugin: Simple Facebook Connect] Connect with FB button not working

  • Joe_HotFiber

    (@joe_hotfiber)


    For some reason, I cannot get the Connect With Facebook button to open a dialog to login to facebook/ allow access, I’ve managed to make it that I can use my personal FB account to post IF i am logged in to FB on that browser already, but that is due to initial set up of the plugin.

    My site (test site, developing new comment system for main site): http://www.quarterturn.co.uk/

    I know it isn’t an issue with my PC because ottopress requires me to “grant permission” correctly/ let me log in.

    Theme uses comments.php style comment system, added the required code from the readme.txt and read everything there trying to resolve issue… any ideas?

    http://wordpress.org/extend/plugins/simple-facebook-connect/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Looking in the javascript console when I load your site shows this:

    FB.Auth.setAuthResponse only compatible with OAuth2.

    I’ve never seen that particular error before, so I looked it up. Found this:

    http://stackoverflow.com/questions/7551419/fb-auth-setauthresponse-only-compatible-with-oauth2-issue

    The solution he gives there is this:

    1.Log in to the Facebook account that is in charge of the App.
    2.Go to https://developers.facebook.com/apps/ and click on the App in question.
    3.In the left menu, under Settings, click Advanced and look at the settings in the Migrations section.

    … switched the “Encrypted Access Token” setting to ‘Enabled’ …

    I checked my own application and found that I had indeed set mine to enabled at some point. So you might check on that.

    While you’re there, also check that “Stream post URL security” is disabled. This has nothing to do with your problem, but it will cause problems with the publisher in some cases if you have that enabled.

    Joe_HotFiber

    (@joe_hotfiber)

    Thanks for that, checked, and my settings are already set to these. One thing I noticed is that it doesn’t work ONLY when you click “## comments” on the bottom of the listed posts on the homepage and the #respond or #comment shows up in the URL.

    And then just as I was about to post this, it still randomly won’t work selecting the SFC button, the STC seems to always work, which is great!

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    It seems to work now on http://www.quarterturn.co.uk/2011/10/test-2/ … Did you change anything?

    Joe_HotFiber

    (@joe_hotfiber)

    It seems awfully temperamental on our site… I haven’t changed anything, but if the end user has issues, I’m sure they could just use the default or twitter method. Thanks for your quick responses.

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Facebook’s code itself is awfully temperamental. Not much I can do about that, they have some rather strange coding practices that don’t always work so well.

    Hi Otto, I need some advice…
    I’m using WordPress 3.0.5 and do not want to upgrade, so it’s not compatible with SFC 1 or 1.1 -(My SFC version is 0.25).

    When I try to Connect to FB to comment I’m getting empty window with this:

    http://snastroenie.tk/?xd_receiver=1&fb_login&#fname=_opener&guid=0.8017686814214668&session=%7B%22session_key%22%3A%222.AQD2bd_Tn1kYOYDb.3600.1320354000.0-1040580916%22%2C%22uid%22%3A1040580916%2C%22expires%22%3A1320354000%2C%22secret%22%3A%22FN5TJSCEoH_fffDeAt0EFg__%22%2C%22base_domain%22%3A%22snastroenie.tk%22%2C%22sig%22%3A%22b92b35836ee7a946b123b461a92db96c%22%7D

    This is my domain: http://www.snastroenie.tk
    And here is an example, where I’m using “Connect to FB”:
    http://snastroenie.tk/4843/biskvitki-na-zvezdichki/

    My migrations setting are as they follow:
    Migrations:
    Remove Deprecated APIs: Enabled
    Stream post URL security: Disabled
    Timezone-less events: Enabled
    Upgrade to Requests 2.0: Enabled
    iframe Page Tab: Enabled
    Require manage_notifications: Enabled
    Forces use of login secret for OAuth call and for auth.login: Enabled
    Encrypted Access Token: Enabled
    Requests 2.0 Efficient: Enabled
    Enhanced Auth Dialog: Enabled
    page_hours_format: Disabled

    I appreciate you work. Thank you.

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    (My SFC version is 0.25)

    Hate to tell you this, but that version will not work anymore.

    Around October 1st, Facebook switched to requiring OAuth 2.0 requests (as well as SSL support in the Graph API). SFC 1.1 added support for these.

    So old versions of SFC will no longer work, anywhere. Upgrading isn’t optional anymore.

    Is there a chance the next SFC version be compatible with 3.0.5?

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    I’m not sure what the specific incompatibility was. Activate it, tell me where it breaks, then I can tell you if a workaround is possible.

    Note that you may need FTP to delete it if it’s breaks your site, so be ready for that.

    There is no “Save” button in “Settings” section.
    I can enter my API Key and Secret, but I cannot save them.

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    General answer for this: You don’t have enough PHP memory, or you have too many plugins activated for same. Varies.

    Increase the available memory to PHP. Google for “php memory limit” for more specific info.

    I’ve no access to change php.ini, but I checked PHP configuration and it was memory_limit 64M. Nevertheless I deactivated all plugins except SFC 1.1, still there is no “Save” button.
    Is it possible to set the data manually? Somewhere in DB, maybe?

    I found sfc_options in wp_options and change its value to
    [Code moderated as per the Forum Rules. Please use the pastebin]

    Now, most of the plugins are working except publish to fan page.
    I’m getting

    API Error Code: 102
    API Error Description: Session key invalid or no longer valid
    Error Message: Iframe dialogs must be called with a session key

    I need go Grand SFC permissions but I have no button to do this.
    I’ll try to find it somehow 🙂

    A strange error:

    Fatal error: Call to undefined function submit_button() in …/public_html/wp-content/plugins/simple-facebook-connect/sfc-base.php on line 207

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Ahh.. okay, the submit_button function was added in WordPress 3.1.

    Sorry, but I think you’re just going to have to upgrade. There’s no significant breaking changes in 3.1 vs. 3.0.5 though. You could try replacing the submit_button function calls with a save changes <input> but I can’t guarantee that it’ll work properly.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: Simple Facebook Connect] Connect with FB button not working’ is closed to new replies.