Simple Facebook Connect
[resolved] cannot post to facebook fan page, have diabled all other plug-ins (4 posts)

  1. faddah
    Posted 3 years ago #


    i recently downloaded and attempted to use your plug-in on a client site to connect their posts to their facebook fanpage for their wordpress web site.

    i have correctly gone in and created, in facebook, an app that connects to the facebook fanpage and copied the app # & secret # correctly to your plug-in settings.

    whenever we try a new test post to see if it also posts to the facebook fanpage, we get the following message on the post editing page from your plug-in:

    “If you can see this, then there is some form of problem showing you the Facebook publishing buttons. This may be caused by a plugin conflict or some form of bad javascript on this page. Try reloading or disabling other plugins to find the source of the problem.”

    we have gone in and turned off all other plug-ins, except for your Simple Facebook Connect, to test this, as you say (by the way, this is quite a pain, as many plug-ins, like jetpack, etc., have to be re-logged into and have all the settings re-set after turning them back on). even with all other plug-ins turned off, we still get this message in trying to do a test post.

    this is in wordprss 3.4.1. we will update to the latest 3.4.2, but we're waiting on the client to back-up their wordpress install and my-sql database first.

    can you please offer any help with this?

    thank you.

    — faddah wolf
    portland, oregon


  2. Samuel Wood (Otto)
    WordPress.org Tech Dude
    Plugin Author

    Posted 3 years ago #

    Most likely cause is that you put your Site URL in the FB application incorrectly. The URL must be exactly correct or none of the javascript will work properly.

    Double check the site URL. Caps matters. Use of www or not matters. That sort of thing.

  3. solutionsphp
    Posted 3 years ago #

    I'm having similar issues. After upgrading to WP 3.4.2, manually publishing to my FB Page (from the edit/add post screen) doesn't work. In place of the two FB buttons, I see the same text as the OP:

    "If you can see this, then there is some form of problem showing you the Facebook publishing buttons...."

    In the settings for the plugin, I see that two tokens checks are failing:

    No User or Access Token found. Try re-saving this page.
    Application Access Token found!
    Fan Page Access Token not found. Try re-saving this page.

    I've tried re-saving the page, no effect. Any ideas? Thank you!

    UPDATE: Disregard! Apparently, re-saving did work! I still see the missing token check messages, but when I refreshed the add/edit post screen, the FB buttons appeared.

  4. faddah
    Posted 3 years ago #


    o.k., i got it to work — you were correct, it was matter of figuring out the correct spelling in the “namespace” field of the developer facebook app to get it to work.

    the problem was — our “namespace” in facebook for the fanpage was the following — http://www.facebook.com/fullofwin.us

    the problem was, developer facebook apps don't like anything but lowercase letters in the “namespace” field, leaving me scratching my head was to what to put in there, as i keep getting errors for “fullofwin.us” and just “fullofwin.” both kept erroring out on me.

    i finally figured out, as it was not really explicitly written anywhere, that you just remove anything that isn't lower case letters in the developer facebook app “namespace” field. just “fullofwinus,” no punctuation at all, in the developer facebook app “namespace” field worked, finally.

    so —

    a fan page like “http://www.facebook.com/mycoolpage.fun”

    would need to be in the facebook developer app in the “namespace” field — mycoolpagefun

    no capitals, no punctuation.

    i would highly suggest, in future updates to your app, you please make this explicit in the instructions in the set-up of your plug-in, letting your users know, step-by-step, that in setting up the developer facebook app, that if their fanpage has any punctuation or capitals in the namespace, then in the “namespace” field set-up, they make capitals lowercase and remove any punctuation.

    in any case, you can now consider this resolved. thank you for the help.


    — faddah wolf
    portland, oregon

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic