Support » Plugin: Simple Facebook Connect » [Plugin: Simple Facebook Connect] Auto-Publish updates don't show up in FB feeds

  • Resolved cozbaldwin

    (@cozbaldwin)


    Since the last big changes to Facebook (addition of ticker):

    The auto-publish to fan page does work. It DOES publish to my fan page. But it never seems to show up in people’s feeds. I can tell this because of the amount of impressions FB shows me each posting gets.

    Then, when I take the same link and organically post the blog link on my fan page, it goes into people’s feeds and then impressions are normal. So its obviously only happening when the auto-publish occurs.

    This happens on at least 3 or 4 blogs that I use this plugin for.

    Is this known? Has anyone else noticed? Am I doing something wrong?

    http://wordpress.org/extend/plugins/simple-facebook-connect/

Viewing 15 replies - 1 through 15 (of 33 total)
  • Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Auto-published updates do show up in feeds, actually. I’ve tested this extensively and it does work.

    What has changed is the new “Top Stories” feed Facebook is showing at the top of the main page. Top Stories rarely shows posts from Pages, of any sort, unless they get lots of interaction. This limits the reach of Fan Pages in general.

    Note that SFC doesn’t have the same issue that has been widely reported recently with “auto-published stories get less than 70% of the likes” and so forth. That story was specifically talking about using third party applications like HootSuite, TweetDeck, and Networked Blogs. When you use those, then your stories get lumped together with all the other pages using the same applications.

    SFC doesn’t have this reduction because you’re not using a third-party application, you’re using an Application that you create yourself and which nobody else is using. Thus, stories published by your application *don’t* get lumped together with a jillion other stories.

    Now, you may have a problem where, basically, you’re posting too often. If you auto-post a dozen stories from your site, then they’re all going to get lumped together into one by facebook’s app-merging thingy on the news feed. In which case, yes, you’ll see a reduction in likes and comments because your stories are being hidden from the news feed. This is the same effect as described in the articles I mentioned before, except that you’re basically doing it to yourself. In which case you should perhaps space out your posts a bit more, or publish them on a delay.

    Bottom line is that posts made by Applications will get lumped together into one in the feed, reducing impressions. However, this only happens when they’re made at close intervals of time. Space them out, or better yet space out your own blog posts, and you’ll get more impressions.

    Appreciate your reply very much. I must reply, though, to inform you that for the pages in question, I never post more than once a day. I understand what you’re talking about 100% though.

    I will do a little more testing and try to come back with some screenshots, as I immediately deleted the SFC posts when I re-posted directly, so I have no proof at this moment.

    For the record, though, I ask friends to make sure they are also not seeing the auto-published posts in their feeds. They confirm they do not see them until I re-post the link directly.

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Just checked my own feed, and I can see the last post I made 16 hours ago in it.

    http://dl.dropbox.com/u/140824/feed.png

    That post was made automatically.

    Edit: Also checked my insights page to see impressions for that story, and it appears that it was seen by slightly less than my total number of fans (about 100 less), so I’d say it’s definitely appearing in the feed for me at least.

    Well I certainly don’t think it’s a fault of SFC. I mostly feared that it was either something I was doing wrong OR something that SFC could be doing differently to appease the Facebook feed gods.

    I have to ask, since your post says it was “posted via Otto on WordPress” and with the wordpress icon there… was that just what you named your app? Or are you using some sort of universal WP app? Mine shows up that it was posted via [my name of app] and my icon.

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Yes, that’s just what I named my FB Application, and what I gave it for an icon. I have another one for ottodestruct.com, named “Nothing to See Here”.

    With FB’s latest updates, it is now possible to use one application on multiple domains and have it work. I have not bothered to do this at this point.

    I apologize for taking so long to come up with an example. Haven’t had much to post recently. But on my most recent try, it still held true.

    Please see attached image. (NOTE: The fan page this was posted to has 90 fans)
    https://picasaweb.google.com/lh/photo/_-2zYSTy6Sd7msHWjTvGi2i8lahl3bZshUv8ZC4N-9o?feat=directlink

    1. You’ll notice the bottom one was posted Monday (October 24th) via SFC auto-publish and received 10 impressions to date. It never showed up in my feed, either.

    2. The top one was the same link, posted organically, just 10 hours ago. It showed up on my feed and it has received 62 impressions so far.

    I still believe this to be some sort of Facebook filtering not unlike Twitter’s behavior of filtering out automatically published tweets from their Search archive.

    (The company I used to work for set it up to post automatically via RSS and we soon realized we were being kept out of the search results and sure enough, they have a policy where they consider that some kind of abuse and therefore banned our feed from showing up in the search. We had to start tweeting organically for almost a year before we started showing up in the Twitter Search again.)

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    You may want to consider “time” as the deciding factor here instead of the feed. Automatically posted items from your own App *do* show up in the feed.

    See, I notice that you auto-posted an item at 1:50am. Not too surprising that it didn’t get a lot of impressions that way.

    On my app page with 1500+ followers, my items constantly show between 600-1000 impressions (average), regardless of whether I auto-publish them or not. However, I generally auto-publish during the day, and there is a strong correlation I see with impressions vs. time. Publishing in the morning (6-10am) gets me the most impressions, for example.

    Time is probably the most important factor, in point of fact. If you publish at night, then when people look at their feeds in the morning, your post is pushed down the page below all the later stuff. Thus it never gets seen. Most FB users do not read their complete feeds, after all, only the latest stuff.

    Note that if you use an application other than your own to publish, like NetworkedBlogs or the RSS importer or similar, then your published post will indeed get lower impressions due to the application collapsing of the News Feed. This doesn’t happen using your own personal application.

    I had a feeling you’d point that out, and I did consider it, but I am pretty confident that’s not playing much of a factor here. And it definitely doesn’t show up in my feed as I am one of the oddballs who can’t read my Facebook without making sure I go back and read all the missed posts.

    I’ll get back to you when I have an example that wasn’t posted in the wee hours of the morning.

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    If it’s not showing up in your own feed, then I have no idea what you could have possibly done to make this happen. Did you hide it somehow?

    Automated posts don’t behave any differently that I can find. I’ve never had the problem you’re describing, and so I really can’t help you solve it.

    I realize that even after proving it, you still won’t have a solution – but I still feel the need to prove it so there’s documentation of it and maybe others out there will ring in with the same issue. So, humor me…. when I do post another example. 🙂

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Hmm.. Yeah, still got nothing. I do know from experience that auto-published items show up. I’ll provide a couple examples:

    https://www.facebook.com/WordPress
    https://www.facebook.com/matt.mullenweg

    Both of those are Fan Pages using SFC with the auto-publisher. With the WordPress one, it’s not allowing other users to comment. With Matt’s, he is allowing others to post on the wall, although obviously only his would show up in people’s feeds.

    Matt’s engagement levels haven’t really changed a lot in recent posts. The WordPress ones have, but only for the latest two posts which were about 3.3 beta releases, so that’s not totally unexpected. Insights show no significant changes, with the impressions numbers generally in the 75-85% of followers range, except for a few popular ones that were widely shared, increasing those impressions numbers way above 150%.

    If we ignore raw impressions and look at the numbers on the new Insights system, the reach is lower on the latest two posts, but the number of “engaged users” remains reasonably constant. The “talking about this” number has actually gone up for the latest beta posts, suggesting that a large number of people are wanting it or mentioning the 3.3 beta somehow. This made a big increase in the “virality” score, which is a stupid name for a measurement IMO. 🙂

    So really, the pure auto-post method is clearly showing to users there, somehow. I doubt it’s all from people visiting that page, since we don’t promote it at all, really.

    I should clarify that I was using the Publish To Fan Page button on the Edit Post admin view for awhile and that always worked without an issue.

    It was when I decided to just set it to automatically post to a fan page upon Publishing of the post that I noticed a difference.

    You may have already realized what I was talking about, but I just wanted to clarify.

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    The manual publisher is manual. Doesn’t go through the application, it’s direct from your browser to FB.

    However, I’ve still been unable to see any significant differences in the two.

    Here you go.

    In fact, to take away the theory that it’s the time posted, I did the exact opposite. The original, auto-published item was done at 8:21pm EST, a prime time. It’s been 4.5 days since then and it garnered 8 impressions (reminder, the page has 90 fans).

    In the middle of the night, 2 days ago, at almost 3am, I organically posted the same link. It’s garnered 73 impressions so far.

    https://picasaweb.google.com/lh/photo/mNlx8v0sulTOKgT3nt7Kw2i8lahl3bZshUv8ZC4N-9o?feat=directlink

    And, for what it’s worth, once again the auto-publish did not show up in my stream and the organically posted one did. Again, my whole point is that it’s not showing up in other people’s feeds either.

    I realize you still don’t have a solution, but I wanted to at least prove it’s happening. I have to wonder if it’s something I’m doing, too; whether it be some setting in the FB app or something else. This is not the only fan page this is happening on either, it’s just the only one I’ve been using recently to give examples. Each fan page uses their own app to post, too.

    Plugin Author Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    I got nothing. It’s not the plugin. Best I can say. Let me know if you work it out.

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘[Plugin: Simple Facebook Connect] Auto-Publish updates don't show up in FB feeds’ is closed to new replies.