Support » Plugins and Hacks » [Resolved] [Plugin: Simple Dropbox Upload] Failed to open stream

[Resolved] [Plugin: Simple Dropbox Upload] Failed to open stream

  • I have a fairly standard set-up. No warning about the plugin not playing nice, but I get this: (php is not my thing)

    Warning: include(HTTP/OAuth/Consumer.php) [function.include]: failed to open stream: No such file or directory in /home/xlsiorne/public_html/wp-content/plugins/simple-dropbox-upload-form/inc/Dropbox/OAuth/PEAR.php on line 47
    Warning: include(HTTP/OAuth/Consumer.php) [function.include]: failed to open stream: No such file or directory in /home/xlsiorne/public_html/wp-content/plugins/simple-dropbox-upload-form/inc/Dropbox/OAuth/PEAR.php on line 47
    Warning: include() [function.include]: Failed opening 'HTTP/OAuth/Consumer.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/xlsiorne/public_html/wp-content/plugins/simple-dropbox-upload-form/inc/Dropbox/OAuth/PEAR.php on line 47
    Error: The HTTP_OAuth_Consumer class could not be found! Did you install the pear HTTP_OAUTH class?
    Fatal error: Call to a member function putFile() on a non-object in /home/xlsiorne/public_html/wp-content/plugins/simple-dropbox-upload-form/wp-dropbox.php on line 21

    Can someone tell me in plain English what I need to do. If I had know WordPress would be this complicated, I would have stuck to making pages from scratch in Dreamweaver.


Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author hiphopsmurf


    The server your on likely is not compiled with Oauth. If your not married to dropbox you could check out my other plugin that’s made for sugarsync and only relies on CURL which most if not all hosts have enabled. http://wordpress.org/extend/plugins/simple-sugarsync-upload/

    Thanks for this solution. The Sugarsync alternative worked straight away. Unfortunately my webhost’s tech support had no idea what I was talking about when I started talking about php PEAR or oAuth. I managed to get the former set up, but not the latter extension.

    I am however encountering a different problem with the Simple Sugarsync Upload in that regardless of whether I set the “Show upload form again after upload?” parameter to true or false, the form does not display again. Only the text I set for a successful upload is there and there is no way to upload another file.

    Refreshing the page doesn’t work, because that resubmits the upload form and so the only way to get the form really is to navigate away from the page and back again. Obviously to anyone who wants to upload more than one file, this falls way out side the realm of “intuitive”. Is there an easy answer as to why this might be happening?

    Plugin Author hiphopsmurf


    Do you by chance have a caching plugin installed? If so you will need to disable it for that page. If not it could be conflicting with another plugin that you have installed with wordpress. I will double check the functionality of the show form option to confirm its not a bug. Not to talk down about your hosting company but if they don’t know what PERL is or how to add the oAuth extension to php then you might consider switching hosts :-/ I know it says pear in the FAQ but that was a typo which I have corrected.

    Thanks for the quick reply. There’s no caching plugin that I’m aware of. To be honest I’m not even exactly sure what type of plugin would fall into that category. The only “unusual” thing about the page is that it has a WP contact form on the same page, but surely that would’t come into play if it’s not filled out in any way. Would it? I don’t know. I’m a designer. I used to make websites from scratch with Dreamweaver and thought WordPress would be an easier, more intuitive alternative with less coding. Boy was I wrong.

    You’re right about the hosting company. I think that outside of business hours, which is when I work on my site, their tech support reroutes to Taiwan judging from the accent. They have no idea what you are saying. They just give you a rehearsed answer and then Google like mad while you’re on hold.

    What can I say… They got Pamela Anderson to do their TV ads a few years ago and it worked. I should have known by the name – Crazy Domains.

    I will try disabling plugins one by one and let you know of the results. If you can suggest what type of plugin could be the culprit that might help. Thanks once again. It’s nice to know there’s life out there in these forums.

    Plugin Author hiphopsmurf


    The issue with showing the form after upload should be resolved is the update that I just put up. Please let me know if you are still having the same issue after the update.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] [Plugin: Simple Dropbox Upload] Failed to open stream’ is closed to new replies.