Support » Plugins » [Plugin: SidePosts Widget] CSS file not working

  • Hi,

    I’ve been editing font sizes and other things in the css file, and the changes aren’t having an effect on the widgets on my page. I’m using the new Mimbo theme.

    Right now the widget just shows up without formatting — all text is the same size (including the headline). Bolding and other formatting doesn’t show up.

    I tried reinstalling the plugin, and that didn’t help.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Have you deleted your browser cache? CSS files are cached, and to see the changes in the file you have to clean the cache or to do a page hard refresh.

    It looks like it’s just this code in the CSS file that’s not working:

    #sidebar ul li.widget_sideposts ul li, #sidebar ul li.widget_sideposts ul a {
    color: #fa6400;
    font-size: 13px;
    padding-top: 10px;
    font-weight: bold;

    I assume this is for post headlines. Immediately after I installed the widget, the headlines looked the same as the other text (not the date, but the post summary). Changing this has no effect, though I see even in this code that the headline should be larger and bolded, which it’s not.

    Even though the other CSS formatting was showing up, I did clean the cache and do a hard refresh. Neither helped.

    I just checked it by changing the font-size to 30 pixels and it worked perfect.

    Just a couple of questions:

    1. Did you look at the page source code in your browser to see if the file is send?
    2. If you send your site URL, it could help to see why it’s not working.
    3. Where can the theme can be loaded? I could not find it on the theme browser.

    I’ve seen some themes that do not include a call to the wp_head() function on the header.php file. Sure it will not be the case, but check it, as the call to this function is required by WordPress API.

    The wp_head() function is in the header.php file. The theme can be loaded at

    As for the page source code, here’s the line about sideposts’ CSS file:

    [huge chunk of code moderated – please use a pastebin or link to file]

    Alright, let me try again – Here’s the code of the line about sideposts’ CSS file:

    <link rel=’stylesheet’ id=’sideposts-css’ href=’′ type=’text/css’ media=’all’ />

    I’m having the same problem as haussamen. I’ve tried refreshing the page several times and have cleared the cache as well and it hasn’t changed anything.

    I’m using the SketchyTheme if that helps. You can find it at:

    Nevermind! I solved my problem! Thanks for looking though.

    You solved it? How?

    Your site send correctly the CSS file. As i tested it, but you have not edited it (I’m receiving the default style.css).

    So, there is no problem sending it. If you edit it and save in the same place, it will work unless there is some cache system on your server that sends the cached file.

    I still don’t understand. Like I said, the style for the date in the widget comes through as it’s supposed to from the CSS file, but the style for the headline is not coming through (the text remains at the normal size instead of at 13px). I have no idea why part of the style sheet is working but not the rest.

    Probably there are any other style sheet that that loads after and overrides it. You have to deal with all your CSS files to see why styles in your site do not work as expected.

    This is the only one that doesn’t work as expected.

    There are some themes that set different styles for widgets different from the default WordPress styles. This is a normal theme developer option. You just have to find out how the theme styles the widgets and style SidePosts depending on this.

    The style.css file is provided as a sample and works with most themes, not all. This is because the style.css file is set for the WordPress default widget styles and different themes can set different style classes and IDs, so, you have to find out which classes and IDs sets your theme and modify the plugin styles to follow the theme styles.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: SidePosts Widget] CSS file not working’ is closed to new replies.