Support » Plugins and Hacks » [Plugin: Sidebar Login] Localisation not working

[Plugin: Sidebar Login] Localisation not working

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have exactly the same problem: I use qTranslate too, all plugins and widgets are localized BUT Sidebar Login. I gave a look at code and it really calls the text domain “sblogin” and mo and po files exist for my language too, but I always see texts in English… πŸ™


    You must remove from line 11 in sidebar-login.php

    load_plugin_textdomain('sblogin', WP_PLUGIN_URL.'/sidebar-login/langs/', 'sidebar-login/langs/');

    and add

    load_plugin_textdomain( 'sblogin', false, dirname( plugin_basename( __FILE__ ) ) . '/langs/' );

    just after line 237

    function widget_wp_sidebarlogin_check() {

    I did it and it works now. I hope the author will fix it asap, anyway.

    I sent to Andy also a new pot file since the old one contained a lot of obsolete strings and was missing few new ones.

    I did so (version 2.3.4) but doesn’t work for me. πŸ™ Still in English.
    I’m trying to hardcode it, but I can’t find the Dashboard and Profile references in the code!

    I like the plugin, but it’s a pity it doesn’t support multilingual websites πŸ™

    You need go to the Sidebar Login options > Logged in links
    <a href="http://yourdomain.com/wp-admin/profile.php?lang=<!--:en-->en<!--:--><!--:ru-->ru<!--:-->"><!--:en-->Profile<!--:--><!--:ru-->ΠŸΡ€ΠΎΡ„ΠΈΠ»ΡŒ<!--:--></a>

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Sidebar Login] Localisation not working’ is closed to new replies.